Layout viewport zoom does not track properly

I’m having a problem in layout recently with zooming within a viewport to a .skp file. I’m used to jockeying around the model by moving the crsr within the viewport, and the zoom in or out will center around the crsr, so it’s easy to move the model sideways within the viewport.
I’m finding the viewport doesn’t center on the crsr when zooming, which means no moving the model around.
anybody familiar with this problem? or found a reason it’s happening?

Better not to zoom in the viewport. There really should be no reason to do that in the first place and doing so opens you up to a world of problems if you add dimensions and/or labels.

Instead of zooming in the viewport, drag the edges of the viewport to crop as needed. Use Preserve Scale on Resize to help with that. If you are using a parallel projection view, set the scale before dragging the sides of the viewport.

Hopefully Dave’s advice will give you a way to achieve what you need, but it is odd that the zooming has changed. I tried in versions up to 2021.0, and they all work in the way zooming works in SketchUp. With 2021.1.2 the way the zoom works was changed.

@trent do you know whether there was an intentional change to how zoom is done with a viewport in LayOut?

Thanks for writing! I’m afraid the other advice is not at all helpful - zooming (and orbiting) within a LO viewport is absolutely a necessary and desirable function to dial in the correct perspectival view of a model, or to simply navigate to the desired part of a model.

I am finding it get squirrelly mostly in my laptop - I’m running SKP 21.1.331 on mac os 10.15.7.

How was the zoom changed? I’m not sure I ever noticed a difference - in SKP i find the zoom operates around the cursor as i would expect.

I’m also checking in LO and finding that it doesn’t matter if i float the cursor over modeled parts or empty space, the way the orbit function in SKP differs greatly depending on where the cursor is placed.

FWIW, when i get the issue it mostly wants to zoom in and out of a spot in the upper left quadrant of the open window.

thx jw

Here’s a .mov of the issue…

This suggests you are not understanding the generally accepted best practice workflow for layout/sketchup. The views you wish to show in Layout should be created as scenes in Sketchup, then you use the linked model to display those scenes in the appropriate viewports in layout. Modifying the Sketchup model from within Layout leads to all sorts of disconnects and double handling.

1 Like

Why not hold shift to pan?

Excellent! Somehow, I have been using SK since the early 2000s without knowing you can use the shift to modify the orbit to get the pan function. i’ve been hotkey back and forth between tools my whole miserable life.

Checking, i find in LO when i click into a viewport it’s automatically in orbit, and won’t hotkey over to pan, which is probably when i started my zoom seesaw technique.

Still curious why the LO viewport zoom behaves differently on different computers on different days with different models, but now i care much less. Thanks for the tip.

Please remember that the developers have dedicated the time and expense of giving us a click-through viewport in LO so that we can adjust a perspective viewport to our liking. It’s a feature!

Additionally, in LO they have given us a Camera pane in the Sketchup Model palette, which is expressly designed to modify the viewport, to give different views of the model in question from a single scene. Thus we can import a model, duplicate it, and obtain as many as nine different orthographic projections of it by modifying the individual viewport of the original single scene.

Also one can toggle back and forth from Ortho to Perspectival view. So one can create multiple copies of the viewport, click into them, and zoom in and out, orbit around (and, as one commenter has helpfully informed me, PAN) to adjust the view which allows one to create an infinite number of perspectival details of the model in the drawing, all from a single scene.

This is a really fast and elegant interface which improves the speed and usefulness of LO immensely; going to the trouble of creating and maintaining all the scenes one needs in a drawing slows down the process enormously, and burdens the SK workflow.

1 Like

It is indeed a feature but it needs to be used wisely. It doesn’t take much digging in the forum to find plenty of examples in which editing the camera position in LayOut has created huge problems for users. As long as you understand the implications of what you are doing, it’s fine. I’ve been using LayOut since the first version and have never found a need to modify Camera properties in any project. It’s easy enough to set up the scenes the way I want them in SketchUp. I might crop the view in LayOut but I never need to enter the viewport to set the camera position.

Note that by default editing the camera position in LayOut is disabled. You have to go into Preferences and enable it.