Layout take hours to update .skp

windows
performance
components
highpoly

#1

Hello,

It takes more than 1 hour for my Layout to update a .skp file, and I wonder why. My Mac Pro has Xeon prosessor, Firepro graphics and max RAM yet seems ultimately slow on this specific file.

The 11 Mb file contains:
Edges: 3571777
Faces: 241612
Groups: 1278
Components: 117
Layers: 28
Materials: 57
Styles: 1

It occupies 2 Gb the OS reports, but very little seems to happen.

Any suggestions?

A solution is very appreciated, or I have to ask my customer to come back some other time (which, off course cannot happen)

Thanks in advance,
Fergos


#2

A 2 Gb SketchUp file is huge. It’s going to take LayOut a while to render. Especially if rendering in Vector or Hybrid.

Perhaps your SketchUp model could do with some clean up. Go to Model Info>Statistics and click on Purge. Maybe you could organize your model better using layers to allow you to turn off groups and components that aren’t visible in the scenes.


#3

Have you imported a lot of things from the 3D warehouse? If so, be aware most of them are grossly over detailed and should be radically simplified before you use them as details in a larger overall model.

See for example this thread:


#4

His post says the file is 11MB.

But says “It occupies 2 Gb the OS reports, …”, which I am guessing is the SketchUp application process.


@Fergos are you sure that you installed the 64-bit edition of SketchUp 2016 ?


#5

On mac you don’t have a 32 bit version.


#6

Thanks guys for all help.

I finally found a component from the Warehouse which had an overload of details, a reconstruction reduced it’s filesize from 4,4 Mb to 159 Kb . the component was repeated 30 times so it figures, sort off.

I purge regularly, and this time I remembered to use ThomThoms CleanUp v3, but it wasn’t before redrawing the “bad” component, purge, repurge and save a lot off times before Layout stopped choking. What a weekend!

Again, thanks for all suggestions, and links

Fergos


#7

Happy to hear you got it to work.It’s a good idea to thoroughly check components you get from the Warehouse before adding them to your models. I think the best thing to do is download them into a separate file, Check them out and do any cleanup there.


#8

Why does this matter when the OP’s profile states he is running SU2016 on Windows 10 ?

Basically what I am getting at is that he maxed out the application process memory limits. He solved it by cleaning up his model and in particular a very “heavy poly” component which had 30 instances.


#9

I was going to ask whether the statistics he showed in the first post were taken with the “show nested components” box enabled. With heavy components, it might multiply the edge/face count shown. Using components reduces file size, but when the file is open, SketchUp still has to deal with every single face and edge.

Anssi


#10

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.