How do I get SU2017 to stay as the default app to open SKP files, on Mac?


#1

I’ve tried to set it using R-click Open With/Other, choosing SU 2017 from the application list, and clicking Always Open With.

That works once if I open a file, then close it, and double click the SKP file again. But if I close the application again, or click on a different file that is v2017, it tries (and fails) to open with SU 2016, which is still showing as the default app on a R click.

Any other options to get the selection to ‘stick’?


#2

Select a skp file in finder, right click and choose get info. In the info dialog choose open with, and then “change all”. (Typing this from memory on my phone. I may have slightly botched a step).


#3

Thanks. I’ll try that tomorrow - on my way to bed now


#4

That’s done the trick - thank you.