Hole In Object With No Apparent Geometry

Greetings all,

First time poster here.

I’m having an issue in Sketchup where holes sometimes appear in my geometry. These holes seem to have no geometry associated with them - no selectable edges, etc. I can’t seem to get rid of it no matter what I do.

It seems to be associated with a Vali Architects Instant Window which has been placed in the wall but I can’t be sure. I’m reaching out to him to see if he has any answers as well.

Does anyone know what this is? Or, more importantly, how I can avoid creating another one in the future? Screenshot attached.

Thanks in advance for any assistance.

Cheers,

Eric

It’s difficult to say for sure without the SKP file but it looks typical of a situation where edges around the hole are on a layer other than Layer 0 and that layer’s visibility is turned off. If I had the model here, I would turn on any layers that are turned off until I see the edges. Then I would select those edges and put them on Layer 0 where they belong. Of course if there are those four edges on the wrong layer, very likely there are others so I would also be checking all the other geometry in the model.

Without the model itself there’s no way of telling for sure, only guessing.
As @DaveR mentioned, we need the model. But my guess is, he is on the right track.
Other than invisible layers assosiated to the “missing” edges it could be a case of hidden edges, not as likely though. Wrong use of layers is more likely.

Leave all basic geometry “on” Layer0 to avoid visibility issues !