Extensions have problem creating WebDialog temporary HTML file

error
webdialog
ui::webdialog
access_denied

#1

Hi Guys, I have a problem with an extension called Flat Text. The problem is a strange error message poping up ever times I want to use the plugin. It use to be once in a while, but now it’s every times. After closing the popup window a few times, sometimes several times, it works. I’ve contacted the owner of the plugin and he couldn’t do anything for me. He think that the problem might on sketchup side. He have contacted the sketchup team and we still wait for an answer… But there is many brains on this community, I toke a chance to post it, see if anyone have an fix for me. You can check the vid to see what the problem is.

My system is SUpro2016, Win7 64b, and the problem happen only when I click on THAT button. I have seen this problem with other extensions but very very rarelly. THX

I just want to add that Flat Text is a great extension and the owner give me a very good support. I hope this post will not affect the quality of his product, or his reputation. Thank you for your comprehension.


#2

that looks like a Timeout when checking for a licence,

are you logged to SketchUp.com before this happens? [ the little man down the bottom ]

I think plugins insisting your online isn’t a good or friendly practice…

john


#3

John, I logged in to sketchup.com (with success) but the problem still happen.


#4

Here’s a reply from the extension creator:

That’s a bug in SketchUp’s WebDialog routines, not in FlatText. It appears to be having trouble creating the dialog window from our HTML file.

One possible workaround would be to make a copy of a FlatText and revise (not edit) the copy. That command uses the standard dialog box, so it avoids the Web Dialog issue. (Edit uses the same WebDialog that Place uses.)

For larger text blocks, you can create a text file and copy-paste between it and the revise dialog.

Sorry this is giving you trouble - it’s an issue between SketchUp and Windows, so it’s out of our control. If enough people complain, maybe Trimble will fix it, or at least tell us developers how to work around it.

By the way, are you using the latest version of FlatText? We’ve fixed a few bugs recently. I don’t think that would fix this issue, but you never know…


Error creating UI::WebDialog temporary HTML pages
#5

@JoeDrafter, when you installed SketchUp, did you right-click the installer and choose “Run as administrator” ?

If not, find the installer (wherever you downloaded it,) and run it via right-click -> “Run as administrator” and then choose “Repair”.


#6

Hello Dan, it’s been a long time and I keep having this problem is it’s now more annoying then ever. I still have it on the extension FLAT TEXT, but also with FREDO TOOLS and VALI ARCHITECT INSTANT FENCE RAILING. I that last one, I have about 10 messages popup everytime I try to pick a fence with the thumbnail. It drive me INSANE!!!

The reason why write now is that I just update to Sketchup 2017 and I though the problem would have stay behind with 2016… but no! it still there. I did update Win7 pro x64 to the latest update, as well as the latest version internet explorer wich I’m not using at all. (Im using chrome).

Any idea guys? The problem is obviously not the extensions.


#7

No, it is a permissions issue (“Access Denied”) for the TEMP folder in the user %AppData% path.

Yes. But you never answered my last question, 7 months ago.

This usually can occur if the software is not installed using administrative privileges. It can also be blocked by security software (ie, anti-viruses, etc.)

So check the TEMP folder’s permissions, and any security softeware to see if perhaps it is blocking access to the TEMP folder, or “sandboxing” SketchUp.exe.


(Moved to Technical Problems category, and removed reference to Flat Text extension in title, because this issue is not specific to any particular extension.)


#8

Thank you to have removed the Flat Text word in the title. It’s a great extension and it work just fine.

A quick question then: Why Windows doesn’t take for grant that I’m the admin for my all system? I’m the only one using this computer. As far as I know, and in user setting, I am the admin.


#9

Because it is a security risk to always run with administrative privileges enabled. (Trojans and Malware and Worms, Oh MY!) So, in Windows 6 and higher being an Admin user is not the same as the machine admin account. They also did away with the ol’ “Power User” account types.


#10

make senses. Thanks for the answer.


#11

Hello Dan Out of no where, the problem came back tonight! The popup error message in many repeated way, just like my first video.

Any (other) idea… thanks for your help.


#12

Find the icon for SketchUp, right-click it with the mouse, and choose “Properties” from the popup menu.

Switch to the “Compatibility” panel, and be sure SketchUp is set to run with administrative priviliges.

Here is image of the dialog of my SU2015 properties, but looks the same for any application icon.

EDIT: This is only a test. To see if the issue can be temporarily solved, in order to point at another course of action. Doing the above will cause drag and drop not to function with SketchUp.


#13

ok, I did tick the box. It was not. I’ll let you know if the problem come back. Thx Dan (again). You are very kind.


#14

Nope! Problem is still there this morning!! Grrrrrrrrrrrrrrrr!:angry:


#15

I’ve been changing the permission on sketchup folder, run as admin (directly by right clicking on the icon) nothing works… I’m absolutly discourage and if someone can help me, I would be really glad.

I know reinstalling windows 7 might fix the all problem but this is something I try to avoid at any cost. I simply DON’T have the time for this… :angry::angry::angry::angry::angry::angry::angry::angry::angry::angry::angry:

Thanks for your help.


#16

I did try! But I ask you questions, and ask that you do some steps, and you never answer the questions, such as this one from last November:

I asked that you do this because your original error message from FlatText said that your access to your user TEMP folder was denied. Ie,

"CreateFile failed for C:\Users\djo\AppData\Local\Temp\skp7081.tmp (Access is denied.)"

If you cannot figure out how, take the machine to an IT repair shop.


#17

I haven’t bothered reading all of this thread !
However, all sorts of subtle and unexpected issues arise if you have not installed SketchUp properly…
The ONLY correct way to do it is to select the installer’s exe file icon [it’s probably in your Downloads folder - but if not re-download it to there]
Once selected, right-click > context-menu > “Run as administrator”

If you have already installed it incorrectly you can try to fix it without a full uninstall and re-install [although that is the fall-back position!].

Close SketchUp.
Run the installer [as administrator], when prompted choose “Repair”.

See if that works…

Note that having admin-powers, or even being logged-in as the administrator, and then launching the installer using the context-menu’s “Run” or double-clicking its icon, is NOT the same thing and will NOT result in a perfect installation for ANY program…


#18

thanks TIG. I tried what you did. Ive tried the “run as admin” way for my 2017 installation and I still have the problem. I’ve been having this problem with SU pro 2015, 2016 and 2017. I also tried the repair idea many times. This morning, change the permission on the temp folder itself. For a weird reason, it fix the problem for a few hours… than it came back. One thing about that incredibly annoying problem is that its completely random. I can be weeks without having it… then one day, the error pop out every time I use a plugin, then go away for a day, then back… That why it make it SOOOO frustrating. Thx for your help, but I’m soon facing the reality of having to reinstall window.