Extended views by chris fullmer awkward

sketchup

#1

Hello everyone,

This is my first post.
Excuse me if this post seems (and it is) very long, but I feel I have to tell the whole story, because it is so peculiar.

Now I’m using a PC based on an Intel i3770, 16 GB RAM and a GTX1060 with 6GB which feeds a 28" FHD and a 40" 4K monitor.

I used to work with SketchUp almost from the start ( from the time Google developed this program), because it is great to design all kinds of technical models which can be 3D-printed. The past few years I had other things to do, but since a week or so, I got into 3D-printing again and of course I re-installed SketchUp.
Versions 2018 … down to 2015, all worked … terrible !
As if someone was constantly altering settings in the background and at a certain point I thought I was being hacked :wink:

After installing Version 2014 however this version was acting predictably and it thus worked fine. Pff … at last !

I installed just two (2) extensions:
a) the STL-export function by SketchUp Team
and
b) the Extended Views by @Chris Fullmer (EV for short)
because it lets you look at the bottom of an object with just 1 click.

However since the installation of the EV some odd things are happening and it seems that the program is not stable anymore.
I.e. using the Push/Pull-function works fine on one occassion and on the next it does not. It is hard to describe what the trouble is but in search of what it could be, I found out that another very awkward thing happened.

Designing a model (for 3D-printing) all of a sudden a giant rectangle with monstrous dimensions appeared. The model that I was designing had dimensions roughly 120 x 70 x 30 mm …
… and at some point I wanted to use the Top View and then the Bottom View using the EV.

The standard views don’t zoom out to get the whole picture, but the EV by Chris Fullmer does (which is very nice by the way !) but it also revealed this very large rectangle with dimension of 10,000 x 10,000 mm (I guess because I did not measure it). And after the discovery of this rectangle the whole program behaved totally unstable.

So far I found out that something was causing problems, but how to solve this ??

Well, since this trouble began I only had installed the EV. The blank installation of Version 2014 worked fine. After installation of the stl-functionality it also worked fine. And at first, after installation of the EV version 2014 also worked fine, but alas … not for long.

So I disabled the EV and uninstalled it.

I rebooted my PC and after that Version 2014 worked fine again.

Problem solved … one would think - no ?

But this morning, I started my PC and SU-2014 and after removing the little guy with moustache …

… I found out, that the EV (with its blue icons) was on top next tot the small toolbar with the normal Views ?!

I checked my Extension Warehouse to make sure that the EV was not there. And indeed it wasn’t. But in View/Toolbars I can opt for Extended Views … although it just isn’t installed ??

And to put this in perspective:

  • When I mark this option (View/Toolbars) the EV-toolbar with its blue icons appear and they are fully functional.
    And after a few minutes of using the program …
    … bingo !!
    There is the giant rectangle with dimensions of 1 meter or so and from that point the program behaves totally erratic.

So … what to do now ?!

I hope someone (preferably Chris himself) can tell me what is going on ? Am I doing something wrong ? Is this EV-extension not for Version 2014 ?

Greetings,
8ch8ch


#2

Hi,

To ‘ping’ someone on this forum use the @ sign in front of their forum name. Thus… @ChrisFullmer stands a better chance of grabbing his attention.


Maybe the question is… Is this VERSION of the EV-extension suitable for SU 2014?

… and I’m not sure what version you’ve installed of the EV Plugin.

Recent releases of SU have had improvements to the graphics handling. If the plugin has been revised or optimized for this stuff, then that might account for the issues you’re reporting.

But, I’m in no position to speculate on Chris’s plugins past what I’ve already done.

So instead, I’ll ask (or maybe it’s a suggestion—even mild prodding) that if you’re going to be troubleshooting this anyhow, then why not focus on getting SketchUp 2018 up and running? instead of resigning yourself to the 2014 edition?

There’s a pretty strong track record of folks successfully installing 2018 onto their systems… and the new installation requirements,…e.g. running as administrator while installing,… and also troubleshooting graphics card drivers… typically solve most of the more common problems.

If you haven’t specifically addressed at least these two items in your previous 2018 installation attempts, then It’s well worth trying 2018 again.


#3

Hello Jim,

First, thanks for the quick respons.

As I wrote, all versions above 2014 don't work stable on my configuration.

Perhaps it has to do with me, still using Win-7 64 bit Ultimate ?

I briefly had Win10 running but there were all kinds of issues with drivers and

progs and utils and although I disabled the pushing-updates (some of them came

thru anyway) the performance compared with Win7 was below par !

Under Win7 however all other progs and utils just work like a jiffy.

I.e. Corelsuite, but also Cyberlink DS-suite, Open Office, several Adobe's and not the

least all kinds of audio & music progs like i.e. Sonar and Ableton etc etc.

These music-progs for instance are quite tricky to get them running properly since

with several midi-devices attached to my system they rely heavily on quick

respons when one is playing (latency).

The load however on the processor and the memory is low to moderate and in the

past I had all three 3D-printers working, while letting a heavy compilation run under

DS4 (ran about 2 hours) and still my system had sufficient reserves to let me use

my Roland A800-Pro and my Akai-EWI-USB.

And all at the same time !!

The taskmanager showed only 9 .. 12 GB Memory Load ...

... while the i3770 was running at just under 80%. (I've looked in my big bunch of

harddrives but I cannot find the screenshot so quickly that I made back then).

Meanwhile I totally uninstalled Version 2014. Ran a total cleanup (registry also)

and reinstalled it with only the STL-extension and now everything runs fine.

But of course I would love to have that bottom-view-util (from EV by Chris) available and

I've always found it to be somewhat odd, that this wasn't built-in right away ?!

Well perhaps an architect isn't that much interested in looking at his design from the

buttom up - no ?

> A practical question:

**- can I edit my post ?

** If so, than I can correct the things you’ve suggested :wink:

Thanks again for the quick answer,

8ch8ch

#4

The pencil icon at the bottom of your post allows you to edit them.



#5

FYI, SketchUp was initially developed and distributed by @Last, which was a relatively small Colorado software company, until it was purchased by Google some years later.


#6

Thanks for the info. I’ve learned a bit more :wink:


#7

Thanks Jim !

I will get to it by this evening hopefully.