As soon as I have updated to Sketchup 2024, it stated that I have exceeded the number of allowed activations.

I did log out of all the devices that I’ve been using since the purchase of the licence; I’ve also logged out of all the older/earlier versions for Sketchup - 2023 and Sketchup 2021 these are the only older versions that I’ve been using.

Additionally, I did deauthorize all devices but that is not working. Is there anything that I’m missing. I did not exceed the number of users, I’m the only user that’s using this software in the office.

Can Anyone here help?

after deauthorizing, log of and on again.

well that was precisely the reason. you can activate 2 sessions at once. either on 2 machines, or 2 versions on one machine.
you had 21 and 23 so you couldn’t start 24.

deauthorizing kicks everyone out. but you might need to get out and in again in 24 because it forces a check of the available sessions.
after that, you can also go back to either 21 or 23. but not both. only 2 at a time.

1 Like

I’ve run into the same problem. I’ve got an iMac and a MacBook Pro, and have (properly) deleted ALL SketchUps- the 2023 I had been using and the 2024 I’ve tried to install. So, yes, even after removing ANY AND ALL SketchUps, it’s still stating I’ve exceeded allowed activations. I have none on the machines, and I’ve deauthorized at least four times. And have restarted the machines twice. So, I’ve got no idea what to do anymore. Any ideas? I mean, I’d love to actually get an account representative from Trimble to see why it keeps showing no spots left when there are no authorized computers.

deleting sketchup doesn’t free a spot.
if you want it to free its spot, you have to log off first.

if you have already uninstalled it, then you’ll have to manually delete the auth token.
follow these instructions.

1 Like

This whole authorization pallava is just too clunky & confusing; regularly in the office I have to help colleagues who get all muddled up.
It would be so much easier if on the Product page where we can deactivate all seats if we could do that for individual seats like in the sketchucation licences page.
Furthermore, we could better keep a tally.
& when SU suddenly decides to “check” and one is at a client’s for a presentation, without an internet connexion, well that’s just fabulous…quickly scrabbling to activate the phone’s hotspot just to go thru that whole messy process of deactivation, log off, log on… so completely annoying.
I can only imagine in offices with ten or a hundred licences how rubbish it is !
Bref, un vrai m****er.


So, if you haven’t deleted an old version, and haven’t used it in a while either, when you launch it, it will tell you to log in (if it’s been more than 30 days). Is this an installation the license server sees as a “login” that counts even though you can’t actually use it until you login again? Does this mean you have to login again just to logout officially?

For Mac:

  1. Close all instances of SketchUp and LayOut by right clicking on their icons in the dock, and clicking “Quit”. Failure to complete this step will prevent these steps from working
  2. Go to your desktop, you should see “Finder” and “Go” in the top left menu bar
  3. Click on “Go” Then hold the Option key and “Library” should appear in the list. Click “Library”
  4. Navigate to Application Support > SketchUp 2024
  5. Delete all files and folders inside this folder
  6. Empty the trash bin
  7. Perform a deauthorisation on
  8. Restart SketchUp and log back in

yeah, if you keep an old version installed but don’t use it, after 28 days, it will prompt you to connect.

as far as I understand, when you login every 28 days, the login_session file knows, and it tells your SU it’s fine for a month, even if you’re away from internet.
So does the server. it knows a version has been activated for 28 days.

once the 28 days have passed, then the login_session file is obsolete, and the server knows 28 days have passed. therefore it doesn’t count as an activated session anymore.

again, as I understand it, when you’re connected to internet and launch SU, the file and server check each other. that’s why deauthorising everything usually works. server says “nobody is authorised”, the file says “well I am”, therefore it updates its status to “ok not anymore”
Looks like in some cases the file doesn’t update its status, maybe it doesn’t talk to the server immediately ? in these cases, deleting the file forces SU to ping the server and recreate a fresh one.

that’s also why people get stuck even after uninstalling several version.
Say you have 22 and 23, both authorised. and you install 24. and immediately get rid of 22 and 23. or maybe someone stole your laptop and you’re making a fresh install of 24 on the new one.
when you connect on 24, the server will see that 2 versions are already activated until their token runs out. because off course, how could the server know that they have been uninstalled (or stolen)?

edit : this is pretty much how it used to work with archicad and the physical usb Wibu key 15 years ago. as a student, I had to update the usb key on a computer with a connexion every month. the usb key was the auth token that I would use offline. and off course, if I lost it, the server wouldn’t know until I reported it.
15 years have passed, but I assume the logic behind is quite the same, not with a physical usb stick anymore but a simple file. Archicad too moved to a virtual wibukey.

I thought I understood … then not … then I guess so.

In my situation, I’m both installing 2024 and setting up a new machine at the same time. I got the “exceeded” message, and ultimately, @colin 's advice in Post #4 (deleting login_session.dat for the 2024 installation on the new machine, and then deauthorize all) got 2024 up and running on the new machine. Going back to my daily driver (2022 on the last machine), it launched fine without having to reauthorize it despite having done deauthorize all. Huh? Well, I guess that makes sense: If it’s set to go till the 28 day timer runs out, it’s not checking yet. Good grief!

I had ArchiCAD versions 7 & 8, and a bit foggy on hardware key. I do remember the hardware key for MacArchitrion - that was a SCSI connector. That wasn’t hot swappable like USB. You needed a full shutdown and restart to make any changes on the chain.

Thank you, Elmtec-Adam! That seemed to clear up any and all cache that got left behind when trying through other methods.

Thank you Elmtec-Adam. This solved my problem.

But this process of upgrading to the latest version of SketchUp should be more seamless. It’s cumbersome and inevitably something goes wrong. Are you listening Trimble??

Please raise a support ticket if you want issues to be noticed. Forum posts are not going to count towards statistics, especially if the issue gets resolved here!