Cursor way too small

Hi
I have installed Sketchup 2017 in my new laptop, Windows 10 + 4K screen.
All menus are looking fine + cursor in menus is looking OK, but - cursor in the workspace is looking way too small. Same when I change it to any command. Almost can’t be seen.
Any idea how to fix it?
Thanks
Rachel

Go to settings>Ease of access>cursor and pointer>change pointer size.

I have tried it. It changes only the cursor size of the menus, and they are fine as I wrote. But it doesn’t change the the cursor size in the workspace of Sketchup, which stays way way too small.

We are not communicating, are you referring to the pointer arrow on the screen and the tool size once one is selected? Can you show a screen shot of what you are trying to change? Exactly what is your windows version?

Yes, exactly. The arrow pointer on the screen, and the tool size once one is selected.
By the way, I have installed Sketchup 2019 as well, and the problem doesn’t exist there

Are you aware that support for high-resolution displays (or better to say for the UI scaling factor) has been gradually introduced starting from SketchUp 2016 to SketchUp 2018? That means SketchUp 2017 has limited support and some items are in wrong scale.

The improvements in your SketchUp 2019 do not automatically appear backported in SketchUp 2017. It won’t ever change for older apps, even if your operating system is updated or your display replaced.


What you can do is to change DPI settings for legacy apps. An app that only knows how to draw itself on an low-resolution display will think it is on a low-res display, then the operating system takes the app’s image and upsamples it. SketchUp 2017 will appear blurry and pixelated, but all items at correct scale.

In Windows 10, you find this by right-clicking on the app icon in the taskbar → Properties → Compatibility → Change high-DPI settings:

  • enable the checkbox :heavy_check_mark:Override high DPI scaling behavior
  • let the scaling be performed by System (not application, since the application does it incompletely here).
2 Likes

Thank you very much for ypur detailed answer.
I have already checked “Override high DPI scaling behavior” with system option,
and the pointer problem arrived after it.

It sounds to me as if the solution is going to be to upgrade to SketchUp 2019 which supports the high-res displays better than SketchUp 2017.

Possible… I would prefer finding a solution with 2017, but if it will not be found, then may be this will be the solution.

Well at this point 2017 won’t be changing so you’d need to change the display scaling or reduce the resolution of the display or go back to a lower res display.