Creating engraved look for image


#1

I have an image that I’m using that will be engraved in wood. I need to be able to reproduce that in a render done using sketchup. I had thought that possibly I could push pull the image or the wood surface it’s going on, but that doesn’t seem to work. If I place the image directly on the surface, it appears there dimensional but on top of the surface rather than inset. I’m sure someone has needed to do this before and might be able to show me the way. I also thought that some plug in might make this easier but so far, no luck. Any help would be appreciated. Here are 2 images before and after rendering.

Thanks



#2

If you want to create the engraving using the image, you may want to apply the image as a texture and then trace the outline in order to manipulate the “engraved” geometry.

CD


#3

Tracing the image would be one way to generate the edges you need to divide the surface of the disk so you can push in the recessed areas. An alternative if the image is a PNG with transparent background is to use TIG’s Image Trimmer available in the Sketchucation Extension Store to do the tracing for you and create the edges you need.


#4

Thanks guys. It is a png and I’ll try that extension. Chris, is there a way to view your video/animation larger?


#5

@blueman537

I created a new animation for you and reposted it in my original post … sorry for the grainy look but it is bigger with less steps in the workflow :slight_smile:


#6

Thanks again. That makes sense but looking at the design I have to work with (and it’s more intricate than what I showed) I think the best option might be the using TIGs Image Trimmer. I did download it and try it but I’m not getting it to work the way I need it to at the moment. I’m going to play with it some more to see if I can get more proficient and if not, I’ll post on his page I guess.


#7

You should post the graphic you want to use on your model anyway. A few of us may want
to give it a try :yum:


#8

Thanks again Chris,

Here’s the graphic in it’s entirety


#9

With TIG’s Image Trimmer as I suggested before.

Although I didn’t do it in this case, I would use 3D text to create the bottom line instead of generating that text from the raster image.


#10

looks beautiful. I have to play with the extension a few times to get it down.


#11

Dave,

I’m working on this now. In order to get the effect to look like yours, I’m able to use the trimmer to gain individual shapes that I can push and pull but after pushing,the resulting look is nothing like what you achieved. Do I need to somehow apply the surface material throughout the entire object. I’m not sure how to do that.Or is there something else I’m missing. You can see that I was able to pus the spiral shape entirely through the object yet I’m not the effect from the front side. Any help would be appreciated.

Thanks



#12

In your second image the “wood” has no thickness.

I laid the result of Image Trimmer on the face of a thin box (a board) and exploded group then pushed in the letters with Push/Pull


#13

thanks again. I guess he “thickness” issue is what I was referring to in terms of making it a solid and not understanding how to do that beyond push pulling and making the entire object a group. I did check the entity info and that group has volume so I assumed that was the same thing. I’m still not understanding the “thickness”. I’m missing something.


#14

Imagine you’ve got a real board and you want to stamp the shapes into it. After you’ve exploded the flay group of letters and the logo, their edges divide the face of the board into inner and outer areas. They define the edges of the stamping. Then use Push/Pull on the faces inside the letters and push it slightly into the board.


#15

Sorry. I’m still missing something. I understand the concept for pushing through an object and have done that before. Here’s what’s happening (I wish I knew how to produce the animation but…)

  1. I produced a rectangle and applied the material and push pulled it to what I thought was a solid rectangle, made a group and placed the image

  2. I ran Image Trimmer and then exploded the component

  3. I selected the spiral face to test.

  4. I used push-pull to push in the spiral and this was the result in the sketchup window

  5. This is what a quick render looked like

5.I went inside the object to see what was going on and this is what I saw

There’s something I’m missing about creating the solidity of the object but I don’t know what it is. Either that or there’s some problem with the way I’m using the image and trimmer.

I appreciate you’re staying with this


#16

Here’s the problem, you are outside the group so the image geometry cannot interact with the block geometry.
Probably easiest at this stage is to explode the block group as well as the image component, this will allow the pushpull on the face to work.
Then group it all when finished.


#17

Great. I’ll give that a try. Thanks


#18

Really sorry. This is getting very frustrating. I had remembered that the only reason I grouped the rectangle in the first place was because it wasn’t working and I had read that the only way to make an object solid with volume is to group it so I decided to try that. I just tried it again, with a fresh rectangle, ungrouped and material applied. Same results.

Pushed up

Imaged imported on face

Image trimmer run and group applied to face

Group exploded

Spiral face selected

Spiral face pushed through. I pushed it excessively this time to show that it’s actually pushed

Resulting appearance in front

Quick render

Obviously, you did it so it can be done. I can’t imagine, using the simplistic object that I’m testing this on and the same png file and the same image trimmer that I’m getting different results.The only part of the process (with the image trimmer) where there could be some discrepancy is that I am: 1. saying Yes to flatten and allow shadows and 2. I Cancel simplifying outline as that leaves me with nothing.

Thanks again in advance.


#19

How about getting your model to the point of the 3rd screen shot. Stop and save it. Then upload it here so we can see what you’ve got.

And leave the textures until the end. Putting them on this early in the process can mask problems.


#20

Thanks, That’s exactly what I was hoping you would say and I have it saved at that point. Here it is:

I’m wondering if there might be some sketchup setting that I don’t have set correctly?

test2.skp (320.2 KB)