CPUs and Multithreading

Windows has a paging file. Is your properly set up?

Do you have Layout set to see the Nvidia drivers in the Nvidia Control Panel? ( It does help )

just a thought - if the model was effectively hidden and only the pixels are generated, then if the model stays static once generated (not editing the model) and then only the movement (rotations views etc) would that be in province of the OpenGL (and perhaps that is what is being done for textures only, but treat the line drawings of the model as texture as well?)

Hello RLGL,
Thanks for the reply.
It’s funny, I thought I was all squared away with my settings and in taking a closer look there was some room for improvement. Steps I took:

  1. I gave up trying to manage the Pagefile myself and found the system seems to run better letting windows 10 manage it for me.
  2. I only have 1 graphics card, and am experimenting with the NVIDIA settings. Not sure if anything has improved from those changes but I need to take a deep dive experimenting with different settings and testing the results.
  3. I took some time to clean up my models. I used Sketchup’s Material Resizer Plugin. This was HUGE in helping reduce overall file size and speeding up both Sketchup and Layout!!! I can’t believe I did not discover this plugin sooner.
  4. Used Meshlab to reduce polycounts on some furniture assets I downloaded from 3Dwarehouse. After this and a good purge performance improved significantly.

Steps 3 and 4 brought my model down from 116 MB down to 64 MB.

Layout does perform much better now, but I know it would be even faster if it could split it’s tasks among the available threads as mentioned earlier.

2 Likes