Component/Group Editing settings not staying

I hope this is the right place to share this, i could not figure out a better way to report this error.

In Model Info - Components - The fade rest of model/similar components settings keep resetting! I keep turning off “hide” rest of model and making it darker as well but as soon as I switch scenes at all the whole model resets to hide rest of model and the bar is set to much lighter!

Sketchup also will not allow me to add standard buttons to any tool bars, like the commands are not anywhere to be found to build a toolbar! I can also only remove buttons by right clicking on the icons.


Have you tried View Menu → Component Edit → Hide rest of model or –>Hide Similar Components?

Sure, I regularly turn Hide Rest of Model on & off.

I turn it off, it is fine, until I switch scenes, as soon as I change scenes it flips back to hide rest of model on and sets the darkness slider back to light. super annoying!

When the toolbars list is open:

Select the word Toolbars to open the menu to allow creation of new…

I can duplicate this although I can’t say I’ve ever run into this before. I have a keyboard shortcut for Hide Rest of Model and just use it.

I have a shortcut for turning Hide Rest Of Model on & off, but I am constantly editing components all day, everyday and I prefer to have this turned off most of the time!

I wouldn’t even really mind except the worst part is that it turns the Fade Rest of Model slider way down also and there is not a quick shortcut for turning that back up!

I guess this may have happened in my Sketchup 2022 before but I never realized it until I tried improving my workflow while setting up 2024.

I’ve attached screen shots of the settings before and after a scene change!

Screenshot before scene change
Screenshot after scene change

I guess this also isn’t new to 2024, but why cant I make custom toolbars with this Command tab like we can in Layout!?
Layout Toolbar Edit Commands Menu

You can only add native buttons to native toolbars. Ruby buttons can only be added to Ruby toolbars.

They have never been compatible.

To copy a native button from one native toolbar to another native toolbar, enter toolbar edit mode via View > Toolbars…, then with both toolbars visible, hold down CTRL while dragging the button. To move a native button just drag it from one native toolbar to another native toolbar.
Pay attention to the position “puck” as you drag the button and release it when this little “puck” is where you want it.

We can. Dave showed you how above.

P.S. - You have opened questions on too many disparate topics in one thread. This makes it hard to assign a solution. In the future, please separate these questions into their own topic threads.

1 Like

I guess when I’m editing components in the model I rarely switch scenes so I haven’t really had a problem with this and I rarely ever need to set the light/dark sliders away from what I have set in my default template.

As for the custom toolbars I prefer the way that’s done in SketchUp. I find it easier to drag tools from toolbar to toolbar. Holding Ctrl while do that copies the tools although you can reset native toolbars later if need. I like having the native toolbars visible so I can see the general order of the toolbars out of the box. I’ve created three toolbars to condense the bars to the tools I want and eliminate ones I don’t want. Just my opinion, though.

1 Like


I know how to edit the native toolbars by dragging and dropping and using this method to create new toolbars, but I did not realize that you can hold CTRL key to create copies of buttons! that is very helpful, thank you.

If you see my screenshot from layout vs Dave’s from Sketchup, there is an extra “Commands” tab which makes building new toolbars really easy and would be a great feature to include in Sketchup as well!

Sorry about my confusing post, I will be better about that in the future!

1 Like

Note the emphasis by me in your original post.

The Fade Inactive and Fade Instance settings are part of the rendering options.

If scenes are set to remember rendering options then when you switch to such a scene, it will revert to what the rendering options were when the scene was last updated.

So, when you make a rendering options change, you’ll need to update the scene(s) that you wish to remember the rendering options as currently set. The rendering options are mostly in the Styles edit panels.

ADD: You’ll notice that the Fade options are not in the Styles edit subpanels. But when you make a change to them or any other rendering / style options, you will need to update the scene with the Style and Fog item checked.

1 Like