Click-Move-Click not working at all on iPad

Trying the click-move-click tutorial on iPad, and am dismayed to find that the Click-Move-Click mode with Apple Pencil doesn’t appear to work at all.

Neither the rectangle draw tool, nor the push-pull tool, is working. Hard-pressing appears to do nothing.

Just draw mode works fine with the Apple Pencil, as do the touch gestures.

IPad Pro with M1, iPadOS 15.4.1, Apple Pencil 2.

Hmm, I’ve never had a problem with it. Do you see the circular progress bar/pressure gauge as you press harder and harder?

Edit: Hmm, I’m not seeing that either but it works. Did that thing go away?

I do not. Pressing harder does nothing, even to the point of bending the screen.

Sorry. There used to be a graphic that showed you how much pressure you were applying, but I guess it was taken out at some point. There is a visual feedback like a blink when you reach enough pressure to click, which is working for me. I’m on a 6G iPad and an Apple Pencil 1, so there’s a chance there’s a hardware problem. Anyone else with this setup?

Hi @leedumond, thanks so much for your feedback!

Note that Just Draw Model and Click Move Click mode are explicit modes. You can switch between the 2 via the settings panel.

You can access the Settings panel by tapping the Gear icon at the top-left corner of the screen.

Yes, of course I did that. I was following the tutorial and the tutorial explicitly states to do this.

Have you tried it with a similar setup as I have described and can verify it works? Maybe I’m doing it wrong? I also watched the Learn video and it doesn’t work at all like it does in the video.

Yep, I’ve got an M1 iPad Pro, 2nd gen pencil, iPadOS 15.4.1, SketchUp version 6.0.4 (1850). And both pencil modes are working flawlessly.

A couple other potentially useless thougths here…

  • Is it possible that the pencil is busted? Are there any other apps that you’re able to use that would help confirm that the pencil is sending info about pressure?

  • Pencil settings? Here’s what I see in the Settings app under Pencil:

  • Maybe try uninstalling and reinstalling the app? BUT BEFORE YOU DO – make sure to backup any files you have stored in the SketchUp app folder under Files app > On My iPad > SketchUp (that folder and its contents get deleted when you delete the app).

My pencil settings look correct. I am thinking it could be the pencil itself at this point. I am going to try a different one and see if it behaves similarly, or at least eliminate that as a possible cause.,

Do you have an Apple store near by to visit and try one of theirs on display or something?

When my pencil doesn’t work right it’s usually because the tip got unscrewed, even if just a bit.

Yep, it was a defective pencil. I tried it on Procreate and Notability and the pressure sensing wasn’t working on those apps either. And I’ve run into the issue before where the tip isn’t fully seated, but that wasn’t the issue in this case.

Bought a new pencil and it’s working as expected now. Very weird. A big Thanks to all who helped me get it sorted out.

1 Like

Thanks for the update. Mike was not going to be able to sleep tonight.

2 Likes