Can't update model in 3DW

I am in the process of updating models I have in the warehouse. For the most part it hasn’t been a problem, but I have 2 models in particular that I can’t update. Popup: “Oops, there was a problem”. I have tried coming back another day, tried both Chrome and Edge browsers, but always same problem. Oddly enough, it looks like my new model was indeed uploaded, but I can’t save changes to the text. Here’s one of the problem models as an example
https://3dwarehouse.sketchup.com/manage/user/u95eaeaca-425c-425e-afdd-eb0fc61e480c?nav=editmodel&pg=3&itemId=dde8f0b2-ef8e-457c-81ad-9235d06c38ce

It uploaded from within SketchUp ok. It did complain about unused materials and component, so I let it purge those.

I can view and download the model from the warehouse fine. But I wanted to change the description and tags a bit, and it gives me the error message when I try to do that.

I am having the same issue with this model: Ukraine International Airlines (Міжнародні Aвіалінії України) Boeing 737-9HX(ER) | 3D Warehouse. I was perfectly able to upload a new model but keep getting error messages when changing the title and description in both Safari and Chrome…

It is now working again, the issue seems to be two low dashes in one tag (in this case: Ukraine_International_Airways) that stopped me from changing the description.