Cannot import .dwg into Layout 2018

Using insert>choose .dwg file (saved in 2013 format)> paper space and tried model space.
Any ideas? I’ve tried different cad files, saved in 2010, tried paper space, then model space and nothing. Not even and error message.
I’m on Windows 7 with 2018 layout. Am I missing something?
Any help would be greatly appreciated.

Can you share the DWG file? How large is it? Maybe it has something to do with the file. Have you tried with other DWG files? Can you import that DWG into SketchUp?

You say you are using LO 2018 but your profile indicates you are using 2019.

Hi Dave,
I’m using Sketchup 2019 but was still on 2018 layout. You made me wonder if 2019 Layout would behave differently. It does. Quick test brought in .dwg no problem. Thanks for your reply, it jogged another idea, so I appreciate it. Still weird that 2018 layout acts differently, but I’ll just move on to 2019. Thanks!

Updated importer in 2019.

Ok-here’s the other issue.
.dwg comes in as a blob. I’ve attached the original .dwg and the layout once its imported. The layout file becomes massive as well

crosstimbers 2 layout example.layout (7.3 MB) TEST CROSS TIMBERS 2.dwg (257.4 KB)

ok- I exploded, ungrouped and purged and it worked. So tracking down what was the culprit

Ok- purge did not change it. Ungroup did not change it.
I had to explode drawing in order for it to work .
Still changed to 6mb file.

We have an issue with the scale of certain acad leader arrows. When the file is inserted, it retains the original scale of the leader heads instead of scaling it correctly with the rest of the info. (In this case 72).

What you can do to fix this in LayOut:

  1. ctrl+a to select the imported info (this will select the scaled group)
  2. From the Shape Style inspector change the Start Arrow to nothing.
  3. Then you double click to enter the Scaled Drawing if you wanted to change the leader lines back.