Black instead of transparent background on exported MP4 animation

Okay so I’ve created an animation (mp4) of the camera just circling around my model and then i export it as an animation with a transparent background but every time i do the transparency just shows as a black background?? The model still completes its 10 second animation, just not with a transparent background. I’ve tried so many ways to fix it and i can’t figure out why it won’t just be transparent. Would anyone know why this is happening? I need to use this mp4 to create a separate layout on Adobe Animate and/or After Effects and every single time I import it, the background is black not transparent. Why does this keep happening??

hello, can you attach a .skp file as an example so we can have a look at ?

I can’t test with animation/import but my mind leaps to Mac OS Dark Mode related issue.

Yes, of course. This is the file I’m working on. It is too large too upload the file itself, so this is a link to where you can download it.
skp file

would it answer your question if I said I don’t have dark mode switched on?

yup yup

In what are you viewing the exported video? If the background is transparent, it would probably be showing the background of the viewer. What would you expect to see for a background? If you want it to be white, set the background to export.

Would this sort of thing work for you? Click on the picture.
Imgur

FWIW, it would be a good idea to make sure you are using Tags/Layers and groups and components correctly.
Screenshot - 2_4_2021 , 9_58_11 AM

And to purge unused stuff from your models periodically.
Screenshot - 2_4_2021 , 9_58_41 AM

Purging unused reduced the file size by over 92%. So down to n easy 7.27 Mb from 95.6Mb.

Yea, I’m still learning how to use sketchup (this is my first time) so the layers are definitely not there haha.
I guess what i’m trying to accomplish when getting a transparent background is I want to be able to import the animation into Animate and add a still image behind it. I want to be able to see everything in the still image except where the building rotating would be. I need it to look like it is hovering and rotating above a table. I have attached the image to this reply so you can see what i’m talking about.
Also, I am trying to keep the “x-ray” style on it so if you think that’s what is causing that’s what’s causing the problem let me know. I tried to export it with a transparent background while not having the x-ray style but it did the same thing i’m having a problem with.

OK. That clarifies why the transparent background. Can you share your MP4 file?

I don’t know about adobe animate, but in after effect, have you tried setting the background in sketchup as green, and then do as told in this tutorial : How to Remove Green Screen in Adobe After Effects CC Tutorial - YouTube ?

1 Like

One issue you will hit in Animate is that you can’t export your timeline including the MP4 that you had imported.

That aside, H.264 doesn’t have transparency, at least not as far as Premiere can tell. Something that would solve the problem for Animate would be to export a PNG image sequence, then import that sequence into Animate. You would be able to export that, and your backgrounds, to a video file.

Here is the mp4 file. mp4

Oh okay i will try to do that. Is it easy to manipulate the green screen to make it look like the image I need as a background?

Ohhh okay that makes sense. How do I export as a PNG sequence from Sketchup?

Wait sorry I misunderstood theYoutube video. I will try to do that now and see if it works.

Okay! success! I followed the instructions in the youtube video and was able to remove the green screen to just end up with the building in after effects. It also works with any color, not just green! Thank you so much. Very helpful.

1 Like

I would still argue to export a PNG sequence, which you can do from the export animation dialog. Choose the PNG option instead of the H.264 one. It will take up more disk space, but it will be like having a perfect green screen version.