Axis precision issues

Please help… I am desperately trying to integrate SketchUp into our architectural workflow and continue to run into roadblocks…

I am using Sketchup as a schematic design tool to develop massing models and plan layouts for our projects. I am a veteran user of SketchUp and have extremely high standards for clean modeling practices. My process is fairly straight forward, I generate a 3D shell based on plan concepts to later generate some 2D plans. My walls are all on axis and I have no issues in either phase of this process.

My models:


Here’s how the plan gets drawn:

The plan is grouped as a component that I can later save it as a unique model to export as a 3D dwg file for the drafting team to use as a background to generate a BIM model. I even go as far as drawing the plan on tags/layers for clarity.

Here’s where we run into problems. When I export the SketchUp generated plan into a DWG, the perfectly orthogonal SketchUp plan turns into a not-so orthogonal DWG. The Line selected below should be 162 inches exactly and at an angle of 180 degrees. As you can see, it’s not the case.

In an attempt to problem solve this I took the SketchUp plan model and scaled it up by 1,000,000X and sure enough I was seeing the same lines in the DWG that are off-axis are now also off-axis in the model. Note that same line that was selected in the DWG is now ~ 13,500,002’-11 3/32" long and off 53/64" off in the Y direction from end to end.

While these are unperceivable anomalies, the fact that the lines rotate by any amount off axis has completely exacerbated in the BIM model causing dimensioning errors and a number of other problems.

So, you somewhat described your process but not what the actual problem is. So to get to DWG you first export your plan component to a separate file, open that and export to DWG? If you want the origin of that export to coincide with the origin of your full 3D model, you must, before exporting the plan, move its component origin to coincide with your model origin. Then, when exporting to DWG, you must use the “3D Model” mode for export. “2D Image” will export your current screen view to DWG but it doesn’t honor the origin of the whole model. I wonder if this was the problem.

Sorry, I hit ctrl+enter on accident and it posted before I was done. I just finished editing.

Here are the Plan files for reference, the SketchUp and the DWG export.
Export_Level 01 Plan_226.dwg (114.5 KB) Export_Level 01 Plan_226.skp (266.6 KB)

You might have Length Snapping turned on. If it is, turn it off. (Window menu>Model Info>Units)
I too like to get things right, even if the deviance in your case is at an atomic scale.

Edit, after taking a look at your file: yes Length Snapping is on. Also, your unit precision settings prevent you from seeing these small errors while modelling.

I checked the dimension on your dwg file and they seem to be the same as your skp file. See attached file.

I looks as you just copied over the original dwg file. It is not totally bad but it is not super precise.

Personally I never trace over a CAD file to avoid problems caused by sloppy CAD. I just use it as reference and when I see a wall that is 33.999999’ long, type 34’ in the Dimension Window. Even very small errors can add up and eventually create angular distortions. These are very very small but they can ruin a model by, for example creating walls that are not aligned correctly and/or walls that have their two faces that are not parallel and thus will prevent push/pulling a rectangle in creating an opening.

With length snapping turned off, and the precision turned to the max on all settings, the color by axis still has my geometry as “on-axis”

There is no way to know if I am 1/10,000th off without exporting. As far as Sketchup is concerned there are no errors.

Edit, thanks for mentioning length snapping. While I never rely on modifying anything without specifying a measurement, it’s good to know that can be disabled.

In this case the original is, I understand, the SketchUp file.

There is a limit to the accuracy of the color by axis style setting. It allows at least 1000 times bigger errors than yours that are truly at atomic particle level.

I see the errors you mention if I change the unit settings to Decimal and allow the maximum number of decimals to display. No need to export or scale.

I think having Length Snapping on when modelling is the culprit. It is a totally useless feature, has always been. It ought to be more (or totally) like a “grid” snap.

Checking with other models of mine that have followed the same process, the anomaly seems to be isolated to this drawing/SketchUp model.

The original model file has a large terrain mesh that was generated from a survey point cloud. I wonder if the model extents are causing the loss of precision at the atomic scale?

I would hide most of the environment when modelling. The inaccuracy might be caused by SketchUp picking up all sorts of arcane inference points from the terrain mesh and Length Snapping acting together.

Confirmed, Hopefully between length snapping being disabled on all future work I’ll be able to avoid the issue.

Yes, all geometry is isolated from another. The context is generally off while modeling and only on for presentation. The building model has its own site grade the matches up with the context at it’s edge. It’s all very impressive if I do say so… :wink:

This is an important takeaway, Color by axis is has relatively big tolerances and is designed for a quick check of geometry. It cannot be relied upon to show small errors and will often give false positives.

To summarize, This thread was created due to a perceived export issue, causing lines to lose precision during the export to DWG. It has been determined that although the lines in the SketchUp model seemed to be exactly as I drew them, they were in fact off on an atomic level, possibly due to the “Length Snapping” being enabled and perhaps also to the numerous iterations that had evolved during the process.

I have regained confidence after testing other DWG exports and finding that this anomaly is isolated to this file and not likely an issue in the export process as we were able to replicate the inaccuracy by changing units/precision in the SketchUp model.

Thank you all for the help. I’ll mark this as solved.