Allow shortening of lower half of dimension extension lines

  • I didn’t want to make one huge combined post which could make the conversation even more confusing and difficult to explain.

  • I wanted the issues to be able to be discussed separately as they are separate issues with the one tool.

  • I wanted different thread titles so that if people were searching for those same issues they could connect with the thread relevant to their question and not get bogged down with all my other particular questions.

  • I thought of the issues at several different points throughout the day and wanted to ask them while I thought of them

Thanks again. I’m sure you guys get a lot of annoying questions on here but we aren’t all here trying to intentionally make your life hard.




Amazing. Thanks! Sorry it didn’t occur to me that the start and end arrow dialogue was controlling that length once you entered the dimension edit mode. The problem is you can edit this after you have created the dimensions but can’t set this shorter length as a parameter before I start creating the dimensions? I.e. as part of my template.

yes you can ! :slight_smile:

ok, it’s quite simple when you know about it :

open your template, and make a dimension. you can make it in the grey if you want. Here, you adjust all the parameters of your template. lines, length, colour, all.

Capture d’écran 2023-04-21 à 11.08.14

then use the eyedropper on this dimension. and from now on, all the new dimensions I place will have this parameter (anything from the line style or the dimension style panels). If you save your template with this “ready made” dimension on the side, then all you need is to eyedrop it and bam, ready to work.

let me show you

here, first is vanilla,
second I adjusted the top lines length and width, and I moved the textbox on the side. then eyedropper
thirds, you see, some of the parameters remained.

Unfortunately, and it answers some of your other questions, the position of the text is not a parameter in one of the side panel (I mean the distance between the text and the line). and it won’t be kept while using the eyedropper tool.

And yes. I forgot to do it, but if you change the text (size, font location under / over the line) it will register with the eyedropper.

so here on the 3rd line I put some blue lines, a purple text in 6pt and voilà. If I use the eyedropper on it, then all my future dimensions will use this template.

as for moving the text box closer to the line, I don’t see a way to do it by default.

Capture d’écran 2023-04-21 à 11.05.35
I can manually move it (then make the curved line white), but as I said earlier, the eyedropper trick won’t reproduce it because it’s not a parameter, it’s me (or you) physically moving the text box. :confused:

as for the snapping dimensions.

snapping side by side s quite simple, layout keeps the inferences point, so you just need to pull the dimension next to the neighbour, and it’ll snap.

what you can do if you want several dimension to behave as a group is select them and group them, like you would in SU. now if I pull to make the group longer, the proportion will be kept.

Thanks so much. Can’t believe how fast you generated those tests and screenshots. haha. I will will play around with the eye dropper and hopefully get my template sorted!

Shame about the text position not being one of the parameters I can duplicate. When the text sits nice and close on top of the line it reads clearer and saves space. When I compare the same text size to my wife’s Archicad drawings the text sits just above nearly kissing the dimension line.


I’m not working this week. had a week of teaching SU that got cancelled last minute for medical reasons. it’s either stalking the forum or binging netflix :smiley:

it works with many things.
do you like to have your text blocks prepared ? like a standard font + size for titles, another for general text ? then just prepare them both, then use the eyedropper on the one you want to reproduce.

basically, if you adjusted something using a side panel, you can eyedrop it to make it standard.
and if you forgot to eyedrop it BEFORE making other dimensions, then eyedrop your reference, it’ll give you the bucket tool, then bucket the bad dimensions. they’ll fall in line.

@eric-s did a live session on layout recently, it’s in my watch list (or more a “listen then have a look when something you don’t know happens, like a podcast with visual aid” list), but I browsed through it, and what I’m talking about is around the 25 min mark

in the end, you would have a template with, on the side, all or the graphical element just as you like them. then, you would either use them directly, or copy them, or eyedrop them, depending.

It makes that part of the workflow faster, especially if you know what you want.

well, see this as an opportunity, now you have a secret way of knowing who made the plan just by looking at the printouts, SU or Acad :slight_smile:

wait, two things :

  • you don’t actually need to group the dimensions. I remember learning that… in another decade, but it works without grouping, just select all and they’ll stretch.

  • however, if you want them to get close / more distant without stretching (just by moving), it’ll separate them from the model

second situation, I selected all (grouped or not) and stretched. so there is more space between the dimensions, BUT it keeps the same harmony as before.
third situation, I selected all and moved. so it kept the same distance between the dimensions, BUT it’ not attached to the model anymore.

hey @JQL the answer you’re looking for is discussed in this thread.

Selecting all together and dragging via the arrow tab is how I generally manipulate them… but as you’ve shown in Example 2, this stretches the space between dimensions which is not the desired outcome.

Example 3 is not useful because the dimensions read incorrect values once they detach from the model. Its critical that dimensions remain attached and move as the model changes.

Neither of these help with laying the dimensions out accurately in the first instance. I want to place them accurately on top of one another as I create them. Snapping to set offsets is the default behavior in Revit and Acad.


Capture d’écran 2023-04-21 à 11.55.53

stuff like that ?

have a first line of dimension, then a second line that “adds” them ? then yeah, no “duplicate tool”, you’ll have to remake the new dimension by clicking on the same inferences points as the first.

Capture d’écran 2023-04-21 à 11.57.07
in (my french) layout, if you right click the paper space, you can either snap to objects or grid. or both.

by snapping to objects, you can place dimension on the SU actual points (seeing your screenshots, I’m pretty sure you already know that but hey, others might not)
Capture d’écran 2023-04-21 à 11.59.00

so yeah, to make the two 450 dimensions, you clicked on the points I marked green. and to make the 900, you’ll have to reclick on the top and bottom. no shortcut on this one. as long as you click on the same points, they should snap on top of each others.

yeah, I thought about it, and the best solution I’ve got is exemple 2, but line by line then. select a line of dimension, and stretch it. then select then next one and so on. you’re kinda hitting the limits of layout here,

SO was not created as a CAD tool but a sketch one, they added LO, and it allows you to make plans from a SU file, but still, it’s not as complete as the equivalent in an actual CAD tool.
same way, it’s not as complete as indesign, or powerpoint. It’s sitting at the intersection of the three, able to do a bit of every one but not actually 100%. that’s where the frustration usually starts.

Ive got no problem snapping to parts in my model using object snap. I also regularly use the double click method to move across the model quickly creating a single chained dimensions. My issue is with this:

As you drag out each chain away from the model (in this case dragging a vertical dimension chain horizontally) there is no way to make them snap to one another (other than right on top of one another). You can see my offset drag distances done by hand-eye movement alone are all slightly different. The last one is even accidentally overlapping the second last (see circle). This distance should be set and snap automatically. Having to fiddle them to all look even is tedious.

Regarding your comment that Sketchup was originally conceived as a sketch tool and not a full CAD documentation software…Well I know and accept this but it now has many more users than at the beginning and we are now all paying $400AUD/year for licensing (and more if you go studio) so is it really too much to ask for them to start upgrading some of these basic quirks which are absolutely standard in other CAD programs?

use the grid to cheat. again, I agree, it could be systematic, but now we can just cheat with the grid.
if you enable “snap to grid” (right click on the background) when you do your dimensions, it’ll allow you to be pretty constant. here is an example, snapping to the grid. the first is still not at a precise distance (depends on your building and where the element is compared to the grid), but the rest will follow.

here, the first is aligned on the grid, then the two extra are 2cm away, again snapped on the grid. (and since I’m using vanilla dimensions, I’ve got a nice overlap. i know :slight_smile: )

Yeah I have tried using this in the past but it has two problems:

  1. The dimension tool tries to snap to the grid underneath instead of the precise points I’m trying to find on the model viewport. I could turn it on after creating the dimensions but this again is another step readjusting them all.

  2. The grid spacing is not necessarily quite right to get all the dimensions stacked exactly right. In some situations where we are close to the edge of a page you don’t have the luxury of just pushing each dimensions out by another full grid box. I could set a really fine grid I guess but it might make other operations harder to do on the grid.

Probably my brain has been too slow this morning to follow these various threads about dimensioning in Layout.

Snapping stacked dimensions – if I am understanding correctly ( and I’m not sure I do ), then…

…using the dimension tool will not ( it seems ) snap to another dimension ( oversight bug…? ) but an existing dimension or one that you’ve just created will snap to other dimensions.

Does this help…?


:scream: I’m posting about dimension snapping in a thread about dimension line shortening


I tried to keep my different questions in different threads for clarity but others thought it better to put them all together.

From the responses I’ve had so far 3 out of my 4 questions are not resolvable within the current capabilities of Layout and therefore I want those things logged as feature requests (which is what I thought I was doing when I created Feature Request posts instead of technical help posts in the first place).

To summarize the answers

  1. Yes you can adjust the length of the tail side of extension lines by double click editing each extension line and changing the “end arrow” length. Thanks @paul.mcalenan and @ateliernab. This is clunky to adjust but at least it can be applied at a template level via the eye dropper method. Thanks @ateliernab.

  2. Text position can be moved manually after creating a dimension but it cannot be set by default (or template, or eye dropper) to sit closer to the dimension line upon creation. This is a feature I still request. The dimension text sits too far from the line it relates to by default. It should be nearly touching the line. (Note we don’t use ‘inline’ dimension styles for architectural documents as in the gif above^)

  3. Stacked dimensions cannot be made to snap to one another for consistent offset and rearrangement in Layout. Current methods of dragging a selected group of dimensions stretches them appart rather than moving them as a locked/snapped group. This is a feature I still request.

  4. Layout does not utilise multi-thread/multi-core processing for the operation “Update model reference”. This is a feature I request as It could possibly eliminate the 20 sec blue pinwheel wait times I experience every time I update my model reference.

Thanks very much guys for your help.

(Currently looking up Acad and Revit pricing.haha)

In general, it is best to create separate threads with one feature request only, although it might be tempting to book them al in one. Developers or program managers have to split them up, anyway.
It’s easier to link to one thread.

Now, I am confused :wink:

Besides adjusting the styled dimensions in your templates, you can also setup some scrapbooks with the styles you use most:

Once you activate a(ny) tool and move the cursor over the scrapbook, it picks up the style all in one (text, color, dimension):

(for selecting, it might be best practice to activate a DIM-layer, so you can select them all in one an adjust:

dimensions layout

For me, the padding of the text is most urgent, moving textboxes and setting fill to transparancy is not sufficient. While the vertical alignments work (left, middle, right) the horizontal ones doesn’t (top, bottom anchor)
You can see it snaps to 6 preset positions:


The middle ones help to determine the center position, but should be moved closer to the line:


That’s why you did the right thing when you didn’t mix thread topics and @ateliernab shouldn’t mix everything in one topic.

I got lost in this topic so I won’t try reading everything that was said in the back.

If someone already replied, I’m sorry for double answer, but to remove those extension lines I think you will have to double click a dimension and edit the extension lines. As I don’t like those lines, I hack their dashes to dotted with 100x spacing:

Removing Extensions from Dimension Lines

After doing this you can use the eye dropper to make the new dimension standard.

If that doesn’t solve it, share a Layout file with the dimension and how you want it, and I’ll make another gif to show you how to do it.

1 Like

Setting the gap and length all to zero gets rid of the extension lines for me…

1 Like

Never tried it. I will. Thanks!

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.