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 Want to keep your SketchUp File size low and ensure that 
it renders quickly as you use it?

This guide is best used for prevention. However, for optimizing already-slow models, 
start with slides 1, 2, 3, 12, 13, and 16-18, but then go back and read the rest, too!

This was originally compiled as a resource for a personal client, not for the public, so at that time, I didn’t 
keep track of the various webpages which inspired some of these points of research. Therefore I give grateful 
credit and thanks to the entire SketchUp community for much of the content of these slides, as well as for the 
community’s spirit of sharing and support, from which I’ve learned so much over the years. Feel free to share 

this compilation, and to comment on the slides if you have any further tips to add!
-K Kean

If you are reading this in PDF format, check for the latest version here:
https://docs.google.com/presentation/d/15iZ_SYGVJcbyHMZJTRjPdZDS5izGibjalp1KDpN-rJM/edit?usp=sharing

AGILE SKETCHUP MODELING

https://docs.google.com/presentation/d/15iZ_SYGVJcbyHMZJTRjPdZDS5izGibjalp1KDpN-rJM/edit?usp=sharing
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Purge
Purge Unused

● Deleting things from the model doesn’t delete them from the model file. 

● Go to Window>Model Info>Statistics>Purge Unused to get rid of deleted Components, Styles, 
Layers, and Materials.

● Do it before every big save to reduce file size in SketchUp.

Improves: File Size

This is very important.

In app.sketchup.com, the Purge 
buttons are in the home      tabs of 
Materials and Components. The 
purge button looks like a recycle 
icon, with three arrows in a triangle.

https://app.sketchup.com/
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Styles

Improves: Rendering

Styles “Profiles” really slow down your model and can make things look 
weird and cartoonish. Try turning them off and then updating the 
style and updating the Scene to save that new Style, if applicable.

Doesn’t that look better? It speeds up your model, too!
Make sure to save the new style and update existing scene styles.

Tip for vegetation: an extension called “Hide Edges” makes plants look much better:

If you are modeling in 
app.sketchup.com, 
you can get rid of 
profiles and choose a 
faster style by going to 
Styles, then selecting 
the “Shaded with 
Textures” style in 
Default Styles. 
“Shaded” is even faster, 
but it colorizes textures 
(temporarily).
You can also just edit 
your current style to 
turn off profiles.

https://sketchucation.com/pluginstore?pln=HideAllEdges
https://app.sketchup.com/
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Styles

Improves: Rendering

Styles

If needed, switch to the “Shaded” 
style while building geometry, as 

textured materials can slow down 
rendering.

Use a “fast modeling” style when building the 
model and save it for your “Working” scene. 

Turn off hidden geometry 
when not editing hidden lines.

A green clock 
means fast 
performance!
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Edge Count

Complexity 
● Use the minimum polygons 

required to communicate the 
essential information.

● Reduce segments on arcs and 
circles whenever possible, 
especially if they will be 
extruded.

Reducing the circle segments from 24 to 
12, and the arc segments from 12 to 6, 
results in a 70% savings in geometry, 
while maintaining a smooth appearance. 
This segment reduction drastically 
improves rendering, especially when the 
component is repeated.

Improves: File Size & Rendering

Edges: 58

Edges: 204

Edges: 696

Edges: 160

Just Right

Too Small

Too Big
(for one leg)
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Edge Count

Complexity in 3D Text

Complex fonts can 
produce crazy-high edge 

counts, thus slowing 
down your model, so 

choose plain fonts 
instead. 

A simple version of this 
sign model only had 

about 500 edges 
(instead of 13,000). 

Improves: File Size & Rendering
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Materials

● Examine image file sizes before importing. Pre-crop and resize images before importing 
them into the model.

● Install and use the Materials Resizer extension from the Extension Warehouse in SketchUp 
(under the Windows menu). 

● For some imported photographs it helps to right-click on model surface and select “Make 
Unique Texture” to further crop and reduce pixels. Undo this step if it makes it too blurry.

● Use .jpg files wherever possible for imported tiling images, as they often have smaller file 
sizes than pngs. Some exceptions are site maps, logos,  and images with transparencies.

● Don’t choose a tiling image file when a flat formulaic color will do. Example: You can usually 
use a flat shade of grey instead of “brushed aluminum.”

● Don’t add decorations to a client’s model, such as wall art, unless asked to.

Improves: File Size & Rendering

2.1 MB 471 KB 217 KB

Materials
Original Cropped Resized
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Imported Components

Imported Components
● Only download a component/model from the 3D 

Warehouse after you have checked the file size and the 
edge count. Shop around a little, it’s worth it.

● Use the component with the smallest file and edge count 
that will do the job. 

● You can always trade up to a higher quality component 
later with a “select/replace” technique.

Improves: File Size & Rendering

This tree file size is 
huge. Aren’t you glad 
you checked before 

downloading?

This tree file 
size is much 

more 
reasonable.

After searching, adjust the sliders!

Tip: LandFX makes 
nice lower-poly 
vegetation models

https://3dwarehouse.sketchup.com/
https://3dwarehouse.sketchup.com/
https://3dwarehouse.sketchup.com/by/LandFX
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Components vs. Groups

Components instead of Groups
● Make Components instead of Groups whenever an 

object might repeat, or ever be used in another model. 

● Groups are great for grouping together components, 
such as grouping the landscaping elements together.

Improves: File Size

A model with 100 of the same tree 
component isn’t much bigger in file size 
than a model file with only 1 tree 
component. 

File Size: 
101 kb

File Size: 
164 kb File Size: 

135 kb Even if the component 
instances are flipped, rotated, 
colored from the outside, or 
scaled, the total file size 
stays small.
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Components vs. Groups 

Improves: File Size

Need 10,000 trees? Thanks to 
components, the total file size only 

rises to 1.5 MB. Each extra tree 
component instance adds only a 

fraction of a kilobyte.
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Stand-Ins

Improves: Rendering While Modeling

Stand-In (Proxy) Components 

● Save a complex component to your hard drive as a reference back-up. 

● In the model, edit and simplify that component to a few lines, or a rectangle, so that it renders 
more easily than the “real” component. 

● Later, when it’s time to present the model, right click on the component in the model and select 
Reload.

● In the Reloading navigation folder, find the saved component on your computer and select it.

The Select/Replace technique works just as well.

● Use a low-poly tree, for example, until it is time to present the model. 

● When it’s time to show the model, import a high-poly model into the file (place it anywhere).

● Select all of the low-poly components.

● In the Components Window, right-click on the high-poly component and select “Replace 
Selected.”

● Delete the first randomly placed high-poly component.
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Visible Tags (Layers)

Improves: Performance

Turn Off as many Tags (formerly Layers) as possible for various Scenes

Save a “Minimal” Scene Tab 
with non-essential Tags 
turned off so that you can 
quickly return to it, and Save 
the model in that Scene 
before closing the file so that 
the file will open easily the 
next time around.

If the model is acting sluggish, 
try hiding tags you don’t need 
to see right then.

Want to learn more about 
Tags? Check out this article.

https://help.sketchup.com/en/article/3000122
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Shadows and Fog

Improves: Rendering

Turn Off Shadows and Fog

● If the model is acting sluggish, turn off 
shadows and fog while working on the 
model, and before saving.

● Save the “Working” or “Minimal” scenes 
without shadows or fog for quick modeling 
modes.

● Save specific Scene Tabs with Shadows or 
Fog only for quick presentation views, if the 
model complexity is small enough to render 
shadows.
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Save

Improves: (Possibly) Rendering. Also Sanity. 

Save

● Save the model quickly after loading a new material, component, or anything 
that rapidly increases file size.

● If you don’t save the file after importing a large component, the file may 
possibly crash and you’ll lose some work.

● This might be in my imagination, but I think that saving the model after 
importing components speeds up the performance.
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Terrain

Improves: It Depends

Terrain

● Limit the terrain selection to essential areas. 

● If context terrain is important, create an essential Terrain group and a 
contextual terrain group, and then hide all but the essential terrain while 
building the model.

● There are many ways to do this, with varying effects on file size, image 
quality, and rendering.
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Computer

Improves: Performance

Close other Applications
Close any other computer applications that you 
don't need to have running. This might clear up 
some processing power.

Keep SketchUp updated 

You can check whether a new version of 
SketchUp is available in SketchUp under 
Help > Check for update... (PC) or SketchUp 
> Check web for update (Mac).

Keep Your Graphics Driver updated and optimized (Windows Only)

1. If you have multiple video cards, you may need to set which one SketchUp or Layout uses. Please 
follow the steps found here (it has to be done for both SketchUp and Layout). You can also confirm 
which graphics card SketchUp is using from SketchUp’s Preferences menu > OpenGL > Graphics Card 
Details.

2. Update your video card drivers: To find your graphics cards, right-click on your Windows button and 
select Device Manager, open up the Display Adapters item, and you’ll see them there.
  A. If there's an Intel graphics card, follow this link for instructions: https://goo.gl/LV46Rk.
  B. If it's not Intel: https://help.sketchup.com/en/article/36254 

If you run into issues with these graphics card  instructions and can’t follow them, please comment on 
this slide so that we can improve the instructions. If you can follow the instructions, but they just don’t 
help, please follow up via your Support ticket, if you have the SketchUp Pro Support plan.

https://www.howtogeek.com/175281/how-to-force-graphics-options-in-pc-games-with-nvidia-amd-or-intel-graphics/
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CleanUp by ThomThom

Improves: File Size & Rendering

● One of the top extensions in the 3D Warehouse.

● Essential for many reasons, one of which is line reduction.

● Install ThomThom’s library extension before getting CleanUp³.

  Many components in the 3D Warehouse are actually created in another program, and 
then imported into SketchUp. If you turn on hidden Geometry, you’ll see all the extra 
stuff in there. CleanUp can get rid of lines that aren’t serving any purpose. This reduces 
your polygon count, which makes everything better!

  Note: If  you run the extension on a full model, do it before you go to lunch, as it can 
take time to run through a complex model. For some huge models it might be best to 
run CleanUp on selected high-poly portions first, before running it on the entire model.

*** Also, if you are done with your guidelines, go to Edit > Delete Guides to further 
speed up your model.

CleanUp³ Extension by ThomThom

https://extensions.sketchup.com/content/tt_lib%C2%B2
https://extensions.sketchup.com/en/content/cleanup%C2%B3
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Find high-poly items

Improves: File Size & Rendering

What if you have an oversized or slow model?
Part One: Find the High-Polygon items with the “Unbork” script

  This script will check for the highest-polygon objects in your model, independent of object file size, so you can 
replace them with lower-poly objects that will render more easily. The script is found in the following document. 
Try it, it’s fun!

https://goo.gl/G1GmyW
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What if you have an oversized or slow model?
Part Two: Find the high file size items 

  Sometimes a model seems much larger and slower than it should be. How can you clean it up and make it usable? 
One technique is to analyze the file sizes of the Materials and the Components. For Macs, it only works for 
Components, not Materials.

● Open the Materials or Components Window and hit the “In Model” icon (the little house button)
● Click on the Details button.
● Select the option for “Save Collection As”.
● In the file navigation window that pops up, navigate to a place you can find the new folder later (I 

just use the desktop), create a new folder in which to put the collection, and select the folder 
(don’t open it, just select it). Create the collection. Wait a minute (or a few).

● Outside of SketchUp, open up the new folder and set the view to Details View.
● In the file folder, sort the Materials/Components by size so you can see the largest ones. 
● If any of the sizes look too large, you then would want to find that material/component in the 

model and either delete, replace & purge it, or else edit the material in an imaging editing 
program to be a smaller pixel size version of itself.

Many components will be groupings of components, so ignore those and focus on size of the inner 
single-component items. It helps visually to switch the folder view to Large Thumbnails once the list is sorted by 
file size.


