Zoom extents makes my drawing teeny weeny

When I hit zoom extend, my drawing shrinks down ridiculously small.

Then it won’t reverse so I have to quickly exit without saving to get my original full screen version back. I tried copying and pasting into a new template but it pasted in small rather than the full screen version I copied.

I think this is the reason why I can’t ‘send to layout’ from the full screen version either. It opens layout and the wheel spins then nothing, just the blank template I’d selected for it to land into?

Share the .skp file and I’ll fix it for you. There’s something placed a long way from the rest of the model.

So once you have got it full screen again, save a scene the way it looks. Whatever happens thereafter, you can always hit that scene to get the full screen back.

Now you can investigate what is going on with your model:

  • turn on 'View Hidden Geometry
  • turn on all layers
  • turn on section planes
  • turn on guides
  • (in fact make all entities in your model visible)

See if there are entities far away from what you expected and if possible, delete them.
See what ‘Zoom Extends’ does now.
You can go back to the saved scene.

Thank you. I copied just the model and set up a new template, then selected ‘paste in place’ in the new document. It worked, zoom extent works as it should now.

1 Like

So you most likely left behind the (at that time) invisible unimportant stuff. That way your new model covers less more modeling space.