Windows keeps shutting down Sketchup 2017


#1

Sketchup Pro 2017 keeps shutting down. I will get message that Microsoft has a problem and must shut down. I have got one bug splat as well. My graphics card Intel HD 5500 is up to date. Windows ten has been updated and I have updated my graphics card as well and ran Sketchup checkup. Woild SU 2018 correct this problem


#2

Are you using any complicated SketchUp extensions (aka plug-ins) during the session when SketchUp Pro 2017 is terminating abnormally? A mis-behaving extension can crash the process running SketchUp, sadly.

Did this behavior begin recently, and if so can you think of any changes that may have occurred (to the computer, software, hardware, etc.) around that time?


#3

Not using any extensions. Added a few to my computer a few weeks ago. Twilight and Zorro. Should I or can upgrade to 2018 ?


#4

To clarify: you added extensions for Twilight and Zorro, but you are not using them? Did SketchUp Pro 2017 work OK before those extensions were added? I would disable those extensions (via the Extension Manager window within SketchUp), quit and restart SketchUp, and see how it behaves. Some applications interact with SketchUp automatically upon startup, even if you never manually activate any part of the extension.

I can’t say whether SketchUp Pro 2018 would work better for you compared to 2017.


#5

If I disable the extensions , how can I render . Can I reinstall them when needed?


#6

How are you able to render now, when SketchUp shuts down unexpectedly? Does SketchUp only shut down unexpectedly when you have used either of those extensions? You wrote earlier that you are “not using any extensions” which seems in conflict with your mentioning rendering software - unless I misunderstand.

Extensions can be enabled (not re-installed; merely re-enabled from an existing installation) and disabled whenever you need to use them. Restarting SketchUp is often (always?) needed when enabling or disabling an extension, so I’m not sure how that would impact your typical work-flow. But in principle you could disable a suspected extension, restart SketchUp, use SketchUp for modeling for a while. Then when you need to render re-enable the extension (using the Extension Manager window within SketchUp’s GUI) and restart SketchUp, and then make a rendering.

But this is somewhat speculative because I don’t really understand how your are or are not using any extensions, and what is actually causing SketchUp to terminate abnormally.


#7

Sorry for the confusion. Yes I have extensions including Twilight for rendering. However the program does not crash when I am using these extensions, only when I am not suing them… Most of the time the crashes occur within the first 15 minutes when I start modeling.


#8

what is your Autosave interval set at…

john


#9

5 minutes


#10

To expand upon what @TDahl Was getting at, extensions don’t have to be actively used to impact the function of SketchUp. If an extension is installed, it is doing SOMETHING when it is loaded, even if you are not clicking on its icon. If you are having problems with SketchUp crashing regularly, you should disable all extensions and run SketchUp to assure that it is running ok. Then try enabling half of your extensions and run some more. If there are no issues, try enabling another few icons. Keep doing this until you find that enabling a certain extension causes the issue.

Unless you can backtrack to the extension you installed just before you started having problems, this is the best way to track down the trouble making extension.


#11

You’d best find this out by installing it, and running the 30 day trial period that’s automatically built into all of the new SU releases.

If you already have an eye on the notion of upgrading to SU 2018… then there’s something to be said for going to it now. You’ll essential have to start with the base SU install… and then as your adding in all of your must have extensions you can test things out as you build everything back up.


#12

Thank You


#13

Thank you


#14

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.