[Win] Setting Preferences > OpenGL switches off via batch script

Continuing the discussion from SketchUp runs slowly in Windows 10, any ideas?:

set_skp2015_gfx_minimum.zip (353 Bytes)

The included batch script uses reg.exe to switch off the 3 checkboxes in the OpenGL panel of the Preferences dialog. ie:

  • Use hardware acceleration
  • Use maximum texture size
  • Use fast feedback

Right-click the cmd script and choose Run as Administrator. Then try and see if SketchUp will start. You can then test these switches in reverse order, ie fast feedback 1st, until you find the culprit. (But most times it’s hardware acceleration.)

get_skp2015_gfx_settings.zip (398 Bytes)

The above script use reg.exe to write a file named “skp_gfx_settings.txt” to the User’s Desktop. The file contains the graphics setting values for SketchUp 2015 from the registry.


alternatively our free ‘OpenGL Config’ support tool for disabling the hardware acceleration setting from outside SU (download to desktop > launch).

no spyware/malware/adware of course.


I do have a separate cmd script that sets the attributes in the “GLConfig_Display” key to PixelFormat #9. But I’d like SketchUp to set the format.

I forgot to add the reporter script in the 1st post (so I’ll edit and add that.)

I am not familiar with the technical term “washed out my screen.” Can you elaborate, please ?

You can look at the scripts with a text editor. There is no command causing a reboot.

(But I have heard in the Microsoft forums of Win 8.x getting caught in restart loops for other reasons.)

Fist of all, it checks SketchUp registry settings, (in the current user hive,) so the install must have been properly finished (and the installer should have been run via right-click “Run as administrator”.)

If you had uninstalled SketchUp prior to trying to read the registry settings, then there would be nothing to read. (And then error messages from reg.exe would indeed output that message.)

If SketchUp was still installed,… then it sounds like you do not have Administrative privileges, or did not run the cmd scripts via right-click “Run as administrator”. They can also be run by running a cmd shell via the right-click “Run as administrator”, and manually calling the cmd script. (But I’m not going give you shell command lessons here. It is not the place.)

new download link (again)

1 Like

Same as in first post but updated for SketchUp 2016: