Why this hidden geometry only on one side?

geometry
3dtext
hidden
fredoscale

#1

Why do I get this hidden geometry only in one side using FredoScale?

hiddengeometry

This is the file: seven.skp (85.6 KB)

Thank you so much.


#2

That side (and the one opposite it) are curved, so they can’t be covered by a single planar Face. Instead, they are covered by a surface formed by several Faces with softened/smoothed Edges between them. The Edges are showing because you have View->Hidden Geometry turned on.


#3

I understand that hidden geometry should be there, but why isn’t it on the opposite face?


#4

It is, at least when I open your model.


#5

That’s because I upload the file with no modifications.

This is the file with the modification I say, one side has hidden geometry and the other one has not.

seven2.skp (92.1 KB)


#6

Not seeing it.


#7

My bad, I didn’t use fredoscale on the previous file.
I reupload.
seven3.skp (92.1 KB)


#8

Looks like something you would have to ask Fredo! You can erase the line, though, the side of the 7 is planar.


#9

I notice that the entire edge along the “top leg” of the 7 is softened and smoothed. As @TheOnlyAaron pointed out, that must be a choice Fredoscale made - whether on purpose or by accident (i.e. a minor bug) I can’t guess.


#10

Yeah, you’re right.
But it still shows some “shadows” that the other face doesn’t show. But you’re right, it’s probably a question that only Fredo could answer.

shadows

EDIT: should I move topics like this to extensions category?


#11

See the dotted effect along the remaining part of the edge? That segment is softened and smoothed for some unknown reason, despite being a crisp edge. The strange shading is because SketchUp is trying to handle the smoothing around that edge. If you select that portion and turn off those properties using Entity Info, the peculiar shading goes away.

soft and smooth


#12

Thank you so much you all :slight_smile:


#13

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.