Why might I be getting non-90 degree vertical lines from push/pull tool?

I am making a plane for a building slab and push/pulling the plane. When I measure the resultant angle of the surface object just created my protractor tool is telling me the angle from either of the flat planes to the vertical planes is “about 90” (squiggly line 90). Is this a known bug and might this be the cause of geometry created from this plane to trim or push/pull improperly? I have seen this non-90 degree measurement and improper push/pull objects before in another part of my model. I remedied by re-building all my geometry until it no longer showed a non-90 degree vertical for all elements. The push/pull errors disappeared. Is this non-90 degree measurement a pilot error? A known bug? inferences being made incorrectly? Any info appreciated.

1 Like

Sounds like the original face is itself slightly skewed before you pushpull.

But internally, shouldn’t even a skewed surface push pull 90 degrees? say i have a plane rotated in both y,z and x,z, the push pull results should give me 90 degree lines (in relation to the original plane surface) connecting the new plane to the original plane.

Unless you are saying that the initial flat plane is not really a plane at all but has vertices with slightly off z values. As i see it SU should not be creating that as a viable plane. It is true that when i make a simple box versus the polyline shape of the slab I do not see the same non-90 degree lines. But the “poly lines” are fabricated directly from the original world axis lines, hard to find an error there.

Pushpull should extrude at exactly 90 degrees to the original face.

Can you upload the model? People here could then take a look and most likely explain the situation.

I can’t in that I have signed a non-disclosure for the residence, but I may be able to isolate some geometry. Thank you for the responses so far.

non 90 extrusion.skp (78.2 KB)

Attached is the extruded plane (extruded downward). It shows a mix of 90 and non-90 degree vertical lines between the two planes. If the upper plane is indeed a true plane (perhaps there is an extension to diagnose?) I can’t see why the extrusion is created with non-90 degree connecting planes/edges.

You appear to have created a situation that triggers some truly strange floating-point results in SketchUp. The vertices of the smaller left part of your bottom face are an infinitesimal amount higher than those of the right part (see attached). You have to switch to decimal units and max display precision to see the differences (.000001" !!!) but apparently this is enough that SketchUp concludes the angle isn’t exactly 90 degrees. I’ve never seen such a tiny misalignment matter in SketchUp before, but I adjusted the vertices to exact match by moving vertically and inferring from other corners, and then I get exactly 90 degrees! Annotated original version:

1 Like

Err ma god…This is somehow what I was figuring was happening but I have no idea how I could have created, through inference or other, such a small deviation! I surely can’t remember a single time inputting a number so incredibly small. I’m idly wondering if a bug may have caused the initial error.

Well you have given a me a good diagnostic to apply to all my suspect geometry, and there is quite a bit. If you know of any other diagnostic tool which may help bring these malformed groups into alignment I’d appreciate that. Thank’s for the insight and a tool to employ!

This is mildly disturbing. Just out of curiosity, did you use intersect anywhere around the geometry?

Shep

I’d say more than mildly, especially given SketchUp’s famous cleanup tolerance. It’s obviously a finite-precision computer arithmetic issue, but egads what a tiny perturbation!

1 Like

I’ve been working on this residential model for almost two years. It has undergone countless design revisions, However, the slabs of the main house, of which this is one, were certainly not created with the intersect tool (when I started off I was a SU amateur and did not feel comfortable with that tool). It was only after starting a guest house did I notice off 90 degree walls causing errors in my “connections”, creating windows, push-pulling planes. I had to completely re-build the elements from scratch nervously testing every single extrusion for compliance. I believe this error has spread like a vector into the rest of my project and is now causing the same error in my main house revisions.

I’ve had similar errors many times on complex models. Rectangle tool creating non-planar faces— they make up at first, but then, erratically, they don’t. Push-Pull ditto. Inferences ditto. I don’t think I was using Intersect at the time, but perhaps. Is that a cause too?

I don’t know if it has to do with the complexity or some other factor. I did notice that I got better inferences if I paused a beat before clicking.

1 Like

Driving me nuts, any solutions to this? Is it the “enable length snapping” that causes this minute “offness”?

No, length snapping does not cause this. The most common causes of distorted geometry are users moving parts of the model that are connected to other geometry, rather than being isolated in components or groups which is the proper practice, and users not understanding or correctly using inference when modeling.

Both of these are user errors and with experience they can be avoided. If you can share a model that you are having trouble with perhaps we can help diagnose and avoid those problems in the future.

1 Like

I’m working on CNC plans for a bench. I have spent hours trying to find a solution to this problem. Rectangles that were created using axes as guides and then extruded are ~ 90.1, rather than 90, which creates a problem for every fillet (a circular section added to interior corners so the resulting faces are square).

About 1/3 of the fillets pass through to the opposite side. The rest don’t. This is the first cogent explanation of the problem that I’ve seen. So far, I have yet to find a consistent workaround for the “remnant” lines and surfaces – elements that cannot be deleted without removing the entire face they are “part of”, because the push/pull did not go all the way through.

Every once in a while, redrawing a line or the arc or both works. Much of the time it doesn’t. Sometimes, adding a new face solves the problem. But many times it doesn’t. Right now I have half a dozen fillets which, due to this bug, I have found no way to finish.

I uploaded the design file. The issues are on the left side of the “bar” in Layer 0.
CNC-Bench-v2.skp (2.0 MB)

It is best to create rectangles with the rectangle tool in a ‘plane’, in my experience, but the inference system could pick up very tiny edges, or entities on (hidden) Layers etc.

Here, for instance it is a very small edge that could cause these kind of troubles. You cannot depend on the Axes or Plane (holding shift)

tniyedge

The main question is, off course, why that little edge is there?

3 Likes

Thanks, Mike.

I had so much trouble with particular piece, I would up recreating
it, ensuring that every edge was “on plane”. I’m now alert for that
darn “~”, too. Whenever I see it, I replace it with an exact measurement.

That solved most of the problems, for quite a while.

But after making several modifications to the basic box, I began to

see troubles again. I lived with them, in the interests of getting the
project done, but I can assure you I was taking pains to ensure that
everything was orthogonal, all the time.

Around that time, I also started seeing the message, “Wait! There’s
a problem with your model. Don’t panic. We’ll fix it… Okay, it’s fixed.”

But after that message appeared, I’m afraid that the potential for trouble
only magnified.

Sorry if I’m light on details here. But iirc, the pushing away an angled
slice was the beginning of the troubles. As long every line adhered to
an orthogonal axis, everything went well. But once I create a 20-degree
guide, drew line, and pushed away part of the “box”, things began to
slowly go haywire…

eric

Check out this learning site Sketchup Fundamentals Lot of good information!

1 Like

Went through every last one of those Sketchup Fundamentals, RLGL.

They were extremely helpful. But all the same, they did not prepare me for:

  1. Things going slightly off kilter (90 degrees to 90.1) after many push/pulls, especially at an angle.

  2. That “~ 5” means “approximately 5”. (I knew the mathematical symbol, but had no idea they were using it that way. And on screen, a negative push/pull like “- 5” was all too similar!) So if you want 1/8, you should always replace “~ 1/8” with the exact value.

  3. That the axes in the item you’re editing always look right, but even so they might not be an exact match for the major axes–and if they’re not, your push/pulls are going to be in trouble.

  4. To be really alert when drawing a line, to make sure it turns green, red, blue, or purple, in order to make sure it is truly orthogonal (or matching an existing angle, when purple).

In fairness, iirc correctly they tried to tell me about #4. But it didn’t quite understand the importance, as in “Things are going to FAIL if you don’t”.

eric

MeditateBetter.com
author of Bench Yoga

650 814-0370

You can force the inferencing with the arrow keys. Up for blue, left for green, right for red.