Why is this file so big?

This file has modest number of edges and faces (~11,000 edges). Only two built in materials used (Mirror 01 and Steel brushed stainless. Former hidden image deleted, and everything Purged. It’s the top part of a street lamp from the mid 20th century.


Here’s a link to the file (33MB approx)

https://1drv.ms/u/s!Ahi2S1cQ8lBcgatRuOTwRjmCRfAjsQ?e=7xIy4z

All tags turned on (there’s only one aside from Untagged). Nothing extra shows when I View/Hidden Objects, or View/Hidden geometry, and Zoom Extents, except softened or hidden lines in the visible components.

I have a very different file with over 500,000 edges, file size less than 3MB.

What’s bloating this file that I haven’t been able to spot?

I removed the materials and got this.
Large Lucy ESLA two-way.skp (522.0 KB)

There is a huge 2965x1298 material in the file. I haven’t been able to figure out why it doesn’t show up in the “In Model” panel of the materials editor. Examining the skp file (as of 2021 a skp is actually a zip archive and you can see the materials if you unzip), I see it is psd file named “_Large Lucy,psd”, evidently a Photoshop file. I wonder, did you have a reference image for drawing this that you have somehow hidden? Or maybe there is a bug due either to the leading _ on the file name or, if you erased the image, due to SketchUp failing to actually remove it from the file. It didn’t go away when I purged unused…

1 Like

This can be achieved by importing an image, placing it inside a group and sampling the image. It creates a material that doesn’t show in the materials browser.

1 Like

Probing some more, I find that SketchUp thinks this material is used 1752 times, and that is why purge unused doesn’t get rid of it. Potentially @Anssi hit the reason, though that is weird behavior! Also, sampling a huge image to paint another object would seem like a strange action.

Edit: now I see: it is painted on the back sides of some of the faces on the swan neck. So the usages are effectively invisible. You can see this if you open the neck for edit, select a face, and look at entity info. The back side material shows there, but is impossible to select or edit! Further, given the size of those faces, painting them with a huge image texture just results in black!

Yes. It is a bug or a glitch. The sample tool doesn’t react on an ungrouped image, and if you explode an image it becomes quite a regular material. The weirdly crated material behaves for the most part like an image (it shows up even when render mode is set to Shaded etc).

1 Like

Yes I did, but it was unhidden then deleted. But it seems it didn’t go away, even when purged.

I have NO idea how it came to be painted on the back faces of the swan neck!

How do I get rid of it, then?

I suppose I could try copying all the visible geometry and pasting it into a new model.

Or (which I’ve just done) selected all of the swan neck, reverse faces, painted the default material on, reversed faces again, purged materials, saved - and down to a sensible 525KB.

Thanks, Steve, Box and Anssi. I want to credit you all with the solution, but am only allowed to check one post. I thought that somehow the image was ‘stuck’ and Box showed that by deleting all materials. I thought I’d tried that, but it didn’t work for me.

Knowing from Steve that it was somehow painted on the back faces enabled me to see how to fix it.

For me, selecting the neck surface allowed to replace the material in Entity Info with the default in one click. The trick seems to be not to select anything else but the affected surface. One more note: after I had managed to get rid of it it disappeared also from Statistics without a purge. Yes, weird.

The bug is internally archived under SKOR-14402,
The web based modeler has some quirks, too.

I found this texture on the back.