Why is the roof (only) transparent?

Hello SketchUp community,
I can’t figure out why the roof in my carport design (attached) remains transparent.
It’s not caused by X-ray mode.
The roof is Colorbond Surfmist which has been imported into the model as a bmp. I tried deleting that material to force it back to default, but even then adding any colour it is still transparent !?

Suggestions appreciated!
Carport.skp (1.2 MB)

The roof is not transparent. You are seeing bleed through of lines from geometry underneath. This is a result of the way OpenGL renders, as you zoom out things that are very close together in space both the surface and the edge start to show. Since you roof is a single surface (without thickness), the top edges of the beams underneath are seen at a certain zoom out and angle. You can:

Raise the roof (woot!) move the roof panels up in space a few cm to avoid the bleed.

Give the roof thickness. Push pull but with your contoured roof thats tricky.

Open the beam elements below for editing and hide the upper edges, (right click and hide while selected, or eraser tool with modifier key pressed)

Exellent info many thanks @endlessfix
Raising the roof would defeat the purpose of the drawing somwhat.
I tried giving the flat sections a thickness of just 1mm using Pull but it didn’t help
So I resorted to hiding the edges with the eraser and that works.
I must say this feels like a wonky workaround, I’m wondering what thickness is needed to make an opaque material? I’ve never seen this transparency issue before, with many solid shapes.

PS: your video tuition was most impressive and helpful, I must learn how you made that clip !?

1 Like

Another option would be to give the structure under the roof a layer that can be turned off when you are looking at the model from above where those objects wouldn’t be visible anyway.