Why I entered 4'', but the real length it turned out is 4'?

Why I entered 4’’, but the real length it turned out is 4’ ? Does anyone know what is the reason? I am using sketchup 2019 pro in Windows 10. Thanks.

What are your Model Info > Units settings ?
Did you type 4 or 4" ?
If the units are feet the 4 is taken as 4’, you need the " to tell it what you want…
Or change your Units to inches…

Thank you for your reply! I am following the teaching videos so I typed 4’’, but for some peculiar reason it just doesn’t work properly.

Following are my operations:

I entered 4’’ while keep clicking the mouse,


I released the click and the stuff got 4 inches in height.
(it is said that I can only put one image, since I am new here)

Maybe I’d better change to a centimeter-scaled format. :sweat_smile:

Click and release to start the move, move in the direction you want and let go of the mouse and type and hit enter.
Do not hold down the mouse button.

Thank you for your reminder. I’ve tried it out, but it still doen’t work in my computer. It seems ‘’ is always regared as ’ , and I don’t know why. BUT it is easier to draw using your method.

BTW, can I change the size of the object after I created it? If yes, how to do?

The learning Center should answer many of your questions.

Sorry I made a mistake, it’s 4 feet rather than 4 inches. :rofl:

Yes, definitely, and I am just on the beginning of this journey. Thank you for your kindness :fist:

1 Like

Here’s a step-by-step to PushPull a face by 4", irrespective of what the model’s units might be.
Activate the PushPull tool.
Click the face.
Pull it in the direction you want the extrusion.
At this stage its actual dimension is unimportant - when it’s something like you expect click.
Immediately type 4" + enter.
Its extrusion should now adjust to be exactly 4".
When you exit that tool by selecting another tool that dimension is ‘frozen’.
Do not click on the measurement-box - just type what you want then press enter.
You can continue to change the dimension by typing in new values - e.g. 6" or 100mm etc + enter - when you change tool that is the dimension ‘frozen’.

Check that your system settings are not using ‘smart-quotes’ [most common on MACs] - this can swap " for a smart-quote equivalent and mess with some apps…


Incidentally, you seem to be Chinese [?] - so model-units in feet/inches seems to be an odd choice ? Why not use a metric template in m/cm/mm etc ??

I once saw a student type the single quote (’) twice to get the double quote (") character. That would do it. Never would have occurred to me if I hadn’t seen someone else do that.

1 Like

An elaborate instruction! I feel more familiar with this basic operation now. Thank you so much :blush:

Yeah, I am a junior student from China. I use a metric template in feet/inches temporarily to follow the instruction videos. It will be easier for me to do the step-by-step practice using the same unit as the videos.

Exactly! That’s where the problem originates. BTW, I have used the same method to get the double quote in English for a few years. :rofl: You remind me, thank you!

1 Like

Wow, great! As I said, that just came from real world teaching experience. It never would have occurred to me to do that. I have had quite a few Chinese students, and I don’t remember if it was one who did this, but I wouldn’t be surprised for a non-native to see our character set in a different way than I do.