Why doesn't the third mouse button work?


#1

In past versions of Sketchup, I liked to gimble around my model by pressing and holding the third mouse button/wheel. It occasionally lets me do it now, but mostly, no. It’s a new mouse with updated software, so that isn’t the issue, and the old mouse was inconsistent too.

The only thing I can do with the third button/wheel now is zoom in/out.

                                                      ****

On a side note, I hate having to turn off the edge style>profile on each and every new model I start. Who the ^%$# needs “profile”??? This is a final output option that does little to do with the initial startup model, and if anything makes identifying visual line cues harder. Now, because some johnny come lately says “oh, hey. I like this feature, so it should be turned on all the time!” you decided to turn it on for EVERYONE???

PLEASE stop fixing what isn’t broken!


#2

Orbit should work fine with the center mouse button. There’ve been no changes to SketchUp regarding the working of Orbit with the center mouse button. To what is the button mapped in the mouse settings?

If you dislike thicker profiles, you can choose a different style or create your own and make your own default template. Either turn off Profile edges or, as I prefer, leave Profiles turned on but set the weight to 1.Thicker profile edges do have some use while modeling and some folks prefer to model with them displayed thicker.

The default styles for the OEM templates have been as they are for years. This is not the decision of “some johnny come lately”.