What looks like a bug

I’m running Pro 20.0.171, although this issue exhibited in previous Pro 20 iterations.

I am finding that when using push / pull or scale tools, too often the part being manipulated is transformed in unexpected ways. Very unexpected.

Here’s a screen shot of the result of a push / pull operation.

The only solution is to 1) close without saving and reopening the file, or 2) delete the object and recreate it from scratch.

Anyone else seeing this?

Did you mean 20.2.171?. If so, that is the latest for Mac. If this is a bug there isn’t a fix yet.

But, as is often the case, it isn’t possible to tell from a screenshot whether this is a bug, an issue with the specific model, an issue with an extension, or operator error. Can you share a model where you encounter the problem so we can see both whether we can reproduce the problem and whether there is a modeling problem?

Sometimes, this is related to autosave settings, mostly on Windows, though… When the autosave kicks in and you’re in the midst of an operation.
What are your settings? Is the file large? Where do you save?

My mistake, yes, 20.2.171.

I’ve seen this on more than one specific model. It is definitely a possibility that it is a conflict with extensions, I have a number of them loaded that are in intermittent to constant use. As such, probably very difficult to chase down the reason for the behavior.

Here’s a link to the file, if you think reviewing it may shed some light.

I appreciate your efforts!


Interesting point on the auto save. I should turn that off, I find it annoying anyway. It was set to every 5 minutes.

The file is 70 MB at present, destined to become almost twice that, I reckon. And I save to a local folder that syncs with Dropbox. I understand that that is not advised, but it is my workflow and I’m not willing to change that.

Thanks, Mike


You are entitled to do as you wish, but be warned that there are known issues in which SketchUp files saved on a remotely synced folder become unrecoverably damaged.

Playing around with your model, I did not yet encounter any incorrect behavior. Can you point me at some specific thing that triggered the issue, e.g. a face you tried to pushpull or an object you tried to scale? I can’t tell from your image what tags you had visible or what you tried to manipulate. Is the misbehavior repeatable? That is, if you undo and then try again does the same problem occur?

Some things I noticed about the model that may or may not have any relevance to the issue:

  • You have a lot of stuff hidden either via the hidden flag or via non-visible tags. You can’t select things while they are hidden, but possibly they could interact with something you are doing.
  • You are not using tags safely. You have many edges and faces that have a tag assigned, particularly the 3sDetail tag, whereas only Groups or Components should have a tag assigned. Their edge and face contents don’t need a tag.
  • You seem to be over-modeling some things. For example, the reinforcing metal inside the concrete columns uses a lot of edges and faces. Couldn’t these be modeled with less detail, as the builder just needs to know where they go, not details of what they look like?

I created a quick video outlining just what I was doing this most recent time this occurred. It’s almost a daily occurrence.

Regarding the other things you point out:

  • I’m pretty well versed in hiding objects and assigning them as groups or components to tags (used to be layers)
  • the “3s” layers are created automatically with the 3Skeng plug in, and you’re right, they don’t adhere to protocol; but, that plug in is my main workflow, so it is what it is; as to the other faces and edges being assigned as entities rather than only as part of objects, that’s Sketchup’s fault, since exploding an object assigned to a layer tag confers the tag designation to the entity, instead of exploding to layer tag 0, as it should. I use explode to 0 plugin a lot, but not always. this is a native problem with SU that you’d think would have been corrected by now
  • my models are quite detailed, it’s the whole point of my business, to actually build the project in cyberspace just as it would be in real life. I catch A LOT of plan errors and oversights this way. I think I’ve done a pretty good job, over the years, reducing edge count as much as possible. some of the rebar, such as in the slabs, are created with Medeek’s foundation plugin in and I don’t have control over the number of segments created in the round rebar. it is too many, I’ll agree, but the rebar I create myself is 12 sided, I think, a reasonable compromise.

Gosh, I appreciate the in depth look you’ve given this!!

Video link below.


1 Like

You seem to have a 3D mouse as well as several extensions running that all use observers, I guess.
Maybe a conflict between two ore more.
If you want to dig in deeper, start with a clean SketchUp install and keep adding extensions untill it starts popping up again.
Do you always need 3D Skeng? Or in certain phases?
A low loading policy of extensions could be useful here.

1 Like

Thanks for the video. I haven’t been able to get pushpull to do anything strange yet on the model. Scaling the steel columns also seems to work ok.

In your initial image, you showed a wall going off at a diagonal. Was that produced by pushpull or scale?

For pushpull it should be impossible to extrude in any direction except perpendicular to the selected face. That’s inherent to how it works. Going in any other direction would be a serious bug that I’ve never encountered or heard of before.

For scale there are some traps you can fall into. For example, accidentally grabbing a different handle than you wanted will scale in a different way than you wanted. Getting the right handle can be awkward if all the handles aren’t visible or if they are close together. Likewise, forgetting or mistyping the units when you want a specific length will get you a scale factor rather than a new length.

I have seen examples of an extrusion going haywire when it involved one of the extensions that cuts a hole through multiple wall layers. There is yet the possibility some extension is misfiring or clashing with another…

Yep on the 3D mouse, Mike.

I get that a bunch of extensions all loaded can be problematic. Yet, I need to use every advantage I can, so yes I have a lot of extensions installed. I could probably unload a few that don’t get used everyday, but a lot do. I use 3Skeng every day and it’s been that way for 8 years, I bet. A long time.

I’m not the first or will be the last to say it, but Trimble should include more capability in sketchup (yes, I’ve read the “simplicity” arguents) or create a GUI framework within which the developers could program.

As far as taking the time out from daily grind to fresh install etc, not going to happen. That’s Trimble’s responsibility.

I definitely have a love / hate relationship with SU.

The diagonal off shoot was from a push pull operation. As best I can remember, it only popped up in 2020. I held off on 2020 for the longest time.

Scale I understand well. I’ve been dabbling in Sketchup since it was @ Last and it’s been a daily part of my workflow for at least the past 8 years. I think some of the issues I encounter are because I’m trying my best to model at a furious pace. Starting the next operation before the last group / component had closed. Most of what you see in the model at it’s present stage gets copied / past in place into new file / modified or modeled / copy / paste back into the original file replacing the components I started with. It’s the only way I can keep it all from bogging down.

I appreciate your time spent looking through this. Thanks


This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.