Weird Stuttering Viewport Issue

Hello everyone, I am having a weird issue with Sketchup lately after I went from updating my windows 8 to windows 10 OS.

When I try to orbit or anything else in viewport for that matter, there is this consistent stuttering every time I do an action such as orbiting or even drawing a rectangle. I also notice that when I change the window size, the toolbars take forever to realign themselves and sometimes also freezes. Even opening the program with no addons takes over a minute just to load everything.

I was thinking it was my graphics card, but the drivers are updated to the latest version. I had also set the program to my main gpu as default.

The weird thing is I fixed it by running the sketchup application as administrator which completely stopped the weird stuttery lag in the viewport and made it back to normal and opening the program is quick again, BUT now I cannot drag images into the viewport (ex. needing material textures from a personal folder).

Does anyone know why running as admin would fix this issue? I would rather not run as admin and allow me to drag and drop images back into the viewport (unless there is a solution for that). I also tried a newer sketchup version as a trial as I thought it was my current version that had issues, but it still creates the same issue for some reason.

Thanks

If you still have an installer file for SU2017 Pro try to reinstall it by right click on it and choose “Run as Administrator”.
(Just in case, the installer file can be downloaded here : https://www.sketchup3d.de/download/center/#199-181-version-2017 )

Unfortunately, the issue still persists. I also tried it with the newer version. Im kind of baffled as to what is causing the stuttering viewport.

Another things I can think of:

  • If you are on laptop and using external monitors try to disconnect it, if you using desktop try with one monitor only.

  • If you are using a kind of docking station, try it without.

  • Try to “play” with anti-aliasing and fast feedback
    image

  • Switch off edge profiles
    image

I’ve also tried playing with the settings under OpenGL tab but the issue still persists.
I tried to look at my performance in the task manager for my integrated graphics and Dedicated graphics and i noticed something interesting.

When I run sketchup as a normal program and all I do is orbit, The Intel graphics uses about 6-8% whilst my GPU uses 0-2% power. (The stuttering is very apparent. If I orbit fast, my viewport would actually freeze until I stop orbiting, and then the image would update)

When sketchup is running through admin mode and I orbit, The Intel graphics goes up to 21% and GPU goes to 11%. (I can orbit as fast as possible and the viewport is still smooth)

I honestly don’t know why that is the case, even when the program is set to my GPU.