Walk-with-the-camera tool issue


#1

Created a simple Box with one open end. Was able to use Walk-with-the-camera tool to position within the Box to then view outside from within. Next added a simple barred Grill on the open Box end. Again tried to walk through the Grill into the Box, however at the inside boundary of the Grill, the camera view popped completely outside of the Box. In other words I was unable to walk through the Grill into the Box and view the other side of the Grill. I made the Box and the Grill separate groups, when I hide the Grill-group, I’m again able to walk into the Box. Is this normal for SketchUp, or is this a technical issue?


#2

Could you upload the SKP file so we can see?


#3

Yes I can


#4

#1 Box.skp (23.6 KB) This was created with Sketchup 2015, but I got the same results with 2016


#5

This might have something to do with the actual size of the box, which is very small . When you use the walk-tool you can toggle collision on or of ( see the different options for each tool at the bottom left in your SketchUp-window) When you position the camera, it automatically sets the eye-height at a real person’s height! Hence you pop out of the box!

It is for this reason that there’s always a person in the standard templates so you will have a feel of what scale you’re drawing, it’s always best to draw at real size.


#6

Yes, that; but I think collision detection is the key. I encountered the same problem; but when I positioned the camera close to the ground, and disabled collision detection by holding down the Alt key, I was able to walk right through the grille bars and into the box.


#7

Mike, I don’t think size is the issue as I can walk through when the Grill is hidden.

OldCoot, I will try disabling collision detection; is there a setting that permanently disables collision detection?

Thanks to both of you for your responses.

JJ

UPDATE: OldCoot disabling Collision Detection did the trick, in the discussion-model I posted, and in a more complex model that I was most concerned about. Haven’t found a setting to default Collision Detection off, but at least the Alt is quite useful. Thanks again.


#8

This topic was automatically closed after 91 days. New replies are no longer allowed.