Visualizer - How to Install for SketchUp 2016

no, I was referring to the Visualzer plugin files…
i,e, first confirm it still works in v15 by using it , and then move a copy of those Visualzer plugin files…

john

Hi all,

I am also trying to install Visualizer into Sketch Up Pro 2016, I have been using it in the past for Sketch Up Make 2015. I’ve tried following the instructions above but my results are slightly different.

Firstly, when I go “Finder”, then “Applications”, My Imagination Visualizer app sits on its own within the applications folder, it’s not within my Sketch Up 2015 folder. I’ve tried copying just the Visualizer app but it doesn’t register when I open SU 2016.

In “Preferences” within Sketch Up 2016, I’ve tried “install extension” and it maps me to my apps folder, but I’m not able to select Imagination Visualizer as it’s greyed out. Also within this Preferences box, Visualizer is not listed in the list for me to tick.

Worth noting that I’m on a Mac and I a currently using a free trial of Sketch Up Pro 2016.

Can someone please advise?

Thanks!

that is where it should be, the ‘extension/plugin’ files are what require moving…

there are clear instructions at top start of this thread click here

good luck

john

Hello John & Shanna, - and everybody else out there,
I have pretty much the same issues that Shanna has - now after fooling with it so much I have lost the Visualizer folder and rb icon. I had removed the folders from my 2015 Sketchup but the program would still show up and run on my extension’s tab - even though it would not show up in my preferences/extension window. So I completely erased the Visualizer app from my apps window and then it would not run in 2015 anymore. So I reinstalled the program and tried to add the plugin back into 2015 Sketchup but like Shanna it was now greyed out and could not be installed. So I then copied Visualizer from my apps program went into the plugins for 2015 as described above and just pasted the app into the plugin’s folder. Went back to 2015 and ran Visualizer and it ran perfect - but still would not show up in my preferences/extension window.
This is of course like someone who has driven a car all their life but never had an idea whats under the hood - broken down in the desert and moving wires about in the engine compartment trying to see if moving one will save them.
Anyways I did the same with 2016 Sketchup - copied the app from the apps folder and pasted it into the plugin’s folder in 2016 - but this time I got no results and am not getting load errors reports either. 2016 fires up and runs as normal but no recognition of Visualizer. It all makes me sad because I loved that program and am trial testing a couple other ones but they just do not have the simplicity or character of that I prefer in Visualizer - and the simplicity is key at this point - I’ve not the time right now to go through and figure out all the rendering choices that the trials I’m using require- one being Twilight V2 as well as Ambient occlusion. If nothing else can anybody recommend a similar program to Visualizer.
Hope this doesn’t sound like I’m whining - just frustrated that my favorite toy was taken away - and yes I would like to whine and cry about it - but I’m not - lol - but trying hard to get it back from the bullies who took it away.
Thanks much for all the help everybody
Michael

The Visualizer App needs to be in the applications folder:
Then you need to copy the plugin from Library->Application Support-> SketchUp 2015 to SketchUp 2016:

I hope that helps.

I agree that you should put the app back where it belongs…

here’s a ruby script to copy the v15 file into v16 Plugins folder…

copy/paste into the bottom of Ruby Console and hit return, restart SU…

v15_folder = "/Library/Application Support/SketchUp 2015/SketchUp/Plugins/ImaginationVisualizer"
v15_extension = v15_folder + '.rb'

v16_folder = File.expand_path("~") + v15_folder.sub('5', '6')
v16_extension = v16_folder + '.rb'

command = 'ditto ' + v15_folder.inspect + ' ' + v16_folder.inspect + ' && ' + \
'ditto ' + v15_extension.inspect + ' ' + v16_extension.inspect

system(command)

john

2 Likes

Hello to you guys,
Thank you, Thank you, Thank you!!! I can’t say it enough times. I did the copy/paste to the Ruby console and
Visualizer is working in 2016. I really can’t tell you how grateful I am that you guys will take the time to be patient enough to get numbskulls like me through these things. Your are the greatest!!
Have a wonderful weekend and pat yourselves on the back for helping out a lost fool.
Take care
Michael

1 Like

Glad to hear you can now use Visualizer again Michael!

Unfortunately I’m still having issues - I’ve read through the thread carefully, but it looks like the configuration of my files within my applications folder is different to what’s outlined here.

When I go to Applications / SketchUp 2015 - all I have are 3 files there - “LayOut”, “SketchUp” and “Style Builder”. There is no plugins folder within this, nor any separate folders (this is the same for my SketchUp 2016 folder).

Am I looking in the wrong place?

Thanks again in advance!

Yes, you are looking in the wrong place…

it’s hidden in the User/Library and there are a few theards on here to tell you how to find it…

Search for mac plugin folder, by clicking the magnifying glass icon up the top of page…

john

there is any chance to have your add-on for mac user?

HI robertaverardi84,

Are you asking about the VisualizerSceneExporter addon?

Stop stirring up stuff that is not there.

@kimberleydesigner I would recommend you explain your post, at the moment it comes across as both offensive and ignorant.
Perhaps an explanation will change that impression.

2 Likes

That doesn’t explain anything.

Yes I agree. I am helping people not waste their time on Visualizer. I spent ages on it with poor results. So I suggest move on and try another package. The fact that I can get good result using Brigher3d mean others will. An if there was a demand for brighter3d then there will be an option for mac users and also your interjections are pointless. How does that make you feel?

Ok, so now we can actually see what you are talking about.
Intelligent discussion works when people express themselves clearly.
Random Statements can be easily misinterpreted.
Could you fill us in on how people that like the way visualiser works can suddenly like the way Brighter works. Personal choice and all that.

The fact that you didn’t get good results does not indicate there’s anything wrong with Visualizer for SketchUp. A simple Google image search will turn up plenty of images made with Visualizer for SketchUp that contradict your assertion that it is no good.

1 Like

I did not say it was no Good, I said you would be wasting time. Like I said
why dig a hole with a spoon when you can use a shovel.

Thanks for heads up. kimberley

Thanks for all the help guys. My Visualizer for SU16 is up and running now.

However, I had a minor issue which I thought I should share here. I couldn’t see a ‘SketchUp 2016’ folder under ‘Application Support’ despite having SU16 installed and being used for a while. I even had Kerkythea plugin installed so that plugin data must have been in that folder which didn’t exist I suppose?

What I did is; Install SU2015, install Visualiser, go to Macintosh HD/Library/Application Support/SketchUp 2015, duplicate ‘SketchUp 2015’ folder and rename as ‘SketchUp 2016’. Didn’t have much hope but voila! It’s aliveeee! Waiting for my second render now.