Viewer on homepage nor working on all browsers


#1

Hi,
I’ve uploaded a model to 3Dwarehouse - copied the embed code - pasted it into mi html in a Joomla article. Result is perfect when using Safari, not working when using,IE, Firefox or Crome

What am I doing wrong ?


#2

I actually think I’ve found some kind of answer myself.

It seems that many of the major browsers are blocking https - is there a way around that ?

John.


#3

blocking the secure HTTPS… very unlikely:

  • activate JavaScript
  • try a ‘compatiblity mode’ if avail (MS IE)
  • check if your malware scanner filters anything

#4

Yea, that seems kinda unlikely, especially since major sites (google, yahoo) go to https. Sounds like something else is going on here.


#5

Pls check this : https://developer.mozilla.org/en-US/docs/Security/MixedContent/How_to_fix_website_with_mixed_content

The way I see it, these browsers block the content if it’s https content being shown on a http website…

Or have I got this wrong ?


#6

Fine, but where’s the mixed content? Everything we serve up is over https. Do you have troubles hitting google.com or yahoo.com? They’re https.


#7

I did one better: IE has a “mixed content” setting. I went to a Win7 / IE 8 machine, disabled “mixed content”, and it still worked. So color me skeptical.

-b


#8

Barry,

I’m not trying to criticise - I’m just trying to figure out why I can’t get the embedding to work. We have tested the embedded code on several different computers using different browsers - and even in different countries - with the same result,
. I appreciate that other people can get this to work - and, as I wrote in the first post, I must be doing something wrong… but what ?-)


#9

@Waterproofing Mixed-content blocking means that IFrames served via HTTP will be blocked, not HTTPS. 3D Warehouse embeds are HTTPS so they should not be blocked.

Is the Joomla article public so that we can see it and try to reproduce the problem?


#10

Found the problem - it was my editor jammin up this. Sorry for the inconvenience :-/