Very slow launch of SketchUp Make 2017 with error message


#1

I have just upgraded SketchUp Make to 2017 version. Opening the application takes a few minutes showing the following error:

Error: #<OpenSSL::SSL::SSLError: SSL_connect SYSCALL returned=5 errno=0 state=SSLv2/v3 read server hello A>
C:/Program Files/SketchUp/SketchUp 2017/Tools/RubyStdLib/net/http.rb:923:in `connect'
C:/Program Files/SketchUp/SketchUp 2017/Tools/RubyStdLib/net/http.rb:923:in `block in connect'
C:/Program Files/SketchUp/SketchUp 2017/Tools/RubyStdLib/timeout.rb:73:in `timeout'
C:/Program Files/SketchUp/SketchUp 2017/Tools/RubyStdLib/net/http.rb:923:in `connect'
C:/Program Files/SketchUp/SketchUp 2017/Tools/RubyStdLib/net/http.rb:863:in `do_start'
C:/Program Files/SketchUp/SketchUp 2017/Tools/RubyStdLib/net/http.rb:852:in `start'
C:/Program Files/SketchUp/SketchUp 2017/Tools/RubyStdLib/net/http.rb:1375:in `request'
c:/users/username/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/progrupa_tools/progrupatools/api_client.rbs:42:in `call_request'
c:/users/username/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/progrupa_tools/progrupatools/api_client.rbs:20:in `get_url'
c:/users/username/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/progrupa_tools/progrupatools/version.rbs:25:in `check_allowed'
c:/users/username/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/progrupa_tools/progrupatools/version.rbs:14:in `is_up_to_date?'
c:/users/username/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/progrupa_tools/progrupatools/updater.rbs:10:in `update_plugin'
c:/users/username/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/progrupa_tools/init.rbs:36:in `<module:ProgrupaTools>'
c:/users/username/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/progrupa_tools/init.rbs:12:in `<main>'
C:/Program Files/SketchUp/SketchUp 2017/Tools/extensions.rb:197:in `eval'
C:/Program Files/SketchUp/SketchUp 2017/Tools/extensions.rb:197:in `require'
C:/Program Files/SketchUp/SketchUp 2017/Tools/extensions.rb:197:in `load'
c:/users/username/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/progrupa_tools.rbs:18:in `register_extension'
c:/users/username/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/progrupa_tools.rbs:18:in `<main>'
SketchUp:1:in `eval'

Any help please?


#2

The error appears to be originating from an extension named “ProgrupaTools”. I’m not familiar with that extension, but does the error go away if you disable it?


#3

@tt_su Looks like an OpenSSL error.

Does the core OpenSSL library work within SketchUp 2017 ?


#4

As @jim_foltz says, your first step should be to disable the progrupa_tools extension and verify that the problem goes away. Then contact the developer to see whether they are aware of the problem and have an update to address it.

The rest of this post is technical - non propellor-beanie types can skip it :wink:

The stack trace says that the “progrupa_tools” extension was trying to contact a server to check for updates, and the connection timed out while waiting for the server to provide its SSL capabilities (the “read server hello A” part of the error message). The Ruby code of the extension would block while waiting for this timeout, and the blocked Ruby would block all of SU, causing the slow launch you observed.

That leaves the question of why the connection attempt timed out. I’m skeptical about @DanRathbun’s suggestion that OpenSSL might fail in SU 2017, as it is part of the core Ruby library not something Trimble developed. Also I’d think other extensions would fail if that were the cause. Based on some web research I see that some servers will silently ignore a client request when there is a mismatch between the SSL versions on the client and server, in particular if the client sets SSLv2 and the server wants SSLv3/TLS. Evidently there are man-in-the-middle attacks possible when using the v2 handshake. That’s a matter of setting a parameter in the extension’s use of OpenSSL, and would indicate a failure to keep it consistent with their own server.


#5

Because the Ruby Core SSL library had bugs previously that Thomas is aware of, as (I think) he actually logged a bug in the Ruby Core tracker on it.

SketchUp had to do some non-standard things regarding SSL.
Like adding a “SSL_CERT_FILE” environment variable to SketchUp’s copy of the environment, that points at a SketchUp delivered certificate (.pem file.)

Users of system Ruby can update their installations to a higher patch level to get fixes to libraries (such as the SSL fix,) but with SketchUp it might require an updated application installer.

Anyway, Thomas knows more about it than we all put together.


#6

Looking at the error log I assumed it must have been some built-in SketchUp PROGRam UPgrade Availability check (progr-up-a) checking for program upgrades on the server. Because it couldn’t contact the server it slowed the launch. I started to turn the internet off on my computer before starting SketchUp and it helped.
jim_foltz made me look at the extensions and I turned out however that it was an extension for users using Polish translation and disabling it did the job - Thank You jim_foltz :slight_smile:


#7

The version of OpenSSL shipped with Ruby up til version OSSL 1.1 is suffering from performance issues. The issue was resolved in OpenSSL version 1.1 and that was first adopted in Ruby 2.4. This means there are no version of SketchUp at the time of writing that isn’t affected by that OpenSSL performance issue under Windows.


#8

This topic was automatically closed after 91 days. New replies are no longer allowed.