Version 21.1.331 Mac Tags Folder Bug


I just updated to the latest version of sketchup this morning (21.1.331). My tags folder is compressed making it really difficult to read my tags (see screenshot). If I try to drag the tag “Name” column bar to the right to expand the column it doesn’t work. It just moves the Name column to the an adjacent column.

1 Like

I am dealing with the same problem
very frustrating

I had seen that too, and a couple of others reported the issue.

The file where the column widths are stored is in this file (you can use the Go menu in Finder, and choose Go to Folder… then paste in this text):

~/Library/Application Support/SketchUp 2021/SketchUp/

Close SketchUp, go to that folder, and rename the PrivatePreferences.json file to some other name. Reopen SketchUp and the columns should be ok.

You may need to reposition palettes afterwards, and set up shortcut keys again.

1 Like

Why aren’t the column widths adjustable like they are in every other palette like this in any other software that exists for macOS? Seems like it’s broken in general and it always should have been adjustable. Weird.


This solution seemed to work with minimal disturbance to my workspace. Thanks Colin.

Double weird: The Tags window column widths ARE individually adjustable in Layout. So somebody knows it’s a good idea.


It’s standard and expected convention. It has been known and nearly enforced for several years throughout the OS and any software written for it.

@trent - I have created bug report SU-49810 in our system.

For everyone else, strangely, deleting the PrivatePreferences.json file does not solve the problem, you need to rename the file.

1 Like

I’m getting the same issue again after renaming the PrivatePreferences.json file. Obviously renaming the file before I open SketchUp every day is not a workable solution. Is there a better fix coming for this?

1 Like

A further update. I’ve now renamed the file twice and now I can’t adjust the column width. So this fix worked once, but now doesn’t work anymore.

1 Like

If your up to a challenge, you might wanna open the Tagpanel.nib file that resides in the package

/Applications/SketchUp 2021/

It should open in Xcode, but that doesn’t come along now anymore, available in the Appstore.
Or replace it with this one: (24,9 KB)
Not the zip, unpack first.
Use at own risk.

Hi @colin,

Is there any more info on this issue? It’s happening to me all the time, despite renaming the preferences files several times.



1 Like

I have the same problem

Mike I don’t know how long it’s gonna last, but it seems to have done the trick at least for me. I have tried everything that I could think of or read everything seemed like it worked and then it broke again.