Validity Check fail SU 2017 Pro


#1

I have a design, that checks out with Cleanup2. I cannot save the design, it fails validity check. It saves, but when I open it, I get the same result as when I have copy/pasted it into another file. I cannot export STL as I get an undefined method ‘-’ for nil:Class.

I have attached two images, one from where I have created the file. The second from when I selected the object (group) and pasted it in a new skp file. Help!!

Full Error message
‘’'SketchUp STL Exporter:
An error occured during export.

undefined method -' for nil:NilClass /Users/NCFatBoy/Library/Application Support/SketchUp 2017/SketchUp/Plugins/sketchup-stl/exporter.rb:226:inget_vertex_order’
/Users/NCFatBoy/Library/Application Support/SketchUp 2017/SketchUp/Plugins/sketchup-stl/exporter.rb:128:in write_face_binary' /Users/NCFatBoy/Library/Application Support/SketchUp 2017/SketchUp/Plugins/sketchup-stl/exporter.rb:98:incall’
/Users/NCFatBoy/Library/Application Support/SketchUp 2017/SketchUp/Plugins/sketchup-stl/exporter.rb:98:in write_face' /Users/NCFatBoy/Library/Application Support/SketchUp 2017/SketchUp/Plugins/sketchup-stl/exporter.rb:76:inblock in find_faces’
/Users/NCFatBoy/Library/Application Support/SketchUp 2017/SketchUp/Plugins/sketchup-stl/exporter.rb:73:in each' /Users/NCFatBoy/Library/Application Support/SketchUp 2017/SketchUp/Plugins/sketchup-stl/exporter.rb:73:infind_faces’
/Users/NCFatBoy/Library/Application Support/SketchUp 2017/SketchUp/Plugins/sketchup-stl/exporter.rb:80:in block in find_faces' /Users/NCFatBoy/Library/Application Support/SketchUp 2017/SketchUp/Plugins/sketchup-stl/exporter.rb:73:ineach’
/Users/NCFatBoy/Library/Application Support/SketchUp 2017/SketchUp/Plugins/sketchup-stl/exporter.rb:73:in find_faces' /Users/NCFatBoy/Library/Application Support/SketchUp 2017/SketchUp/Plugins/sketchup-stl/exporter.rb:68:inexport’
/Users/NCFatBoy/Library/Application Support/SketchUp 2017/SketchUp/Plugins/sketchup-stl/exporter.rb:341:in block in do_options' /Users/NCFatBoy/Library/Application Support/SketchUp 2017/SketchUp/Plugins/sketchup-stl/SKUI/events.rb:82:incall’
/Users/NCFatBoy/Library/Application Support/SketchUp 2017/SketchUp/Plugins/sketchup-stl/SKUI/events.rb:82:in block in trigger_event' /Users/NCFatBoy/Library/Application Support/SketchUp 2017/SketchUp/Plugins/sketchup-stl/SKUI/events.rb:78:ineach’
/Users/NCFatBoy/Library/Application Support/SketchUp 2017/SketchUp/Plugins/sketchup-stl/SKUI/events.rb:78:in trigger_event' /Users/NCFatBoy/Library/Application Support/SketchUp 2017/SketchUp/Plugins/sketchup-stl/SKUI/window.rb:357:inevent_control_callback’
/Users/NCFatBoy/Library/Application Support/SketchUp 2017/SketchUp/Plugins/sketchup-stl/SKUI/window.rb:311:in callback_handler' /Users/NCFatBoy/Library/Application Support/SketchUp 2017/SketchUp/Plugins/sketchup-stl/SKUI/window.rb:269:inblock in add_callback’
SketchUp:1:in `call’’’’


#2

can you upload the .skp file?


#3

I cannot JimD. It’s gets saved in the state of the after image I posted.


#4

What size is that object? If it is very small or has tiny details, you may be running into issues with SketchUp’s handling of short edges.


#5

The after image is what is rendered in the current window when I save the skp. The resulting skp contains the corrupted object.


#6

If you can’t upload the SKP file, can you share what information you are working from? It doesn’t look like an especially difficult model to create. Maybe I could give it a try and see what I get.

What version of SketchUp are you using? Please update and complete your profile info.


#7

Untitled.skp (195.6 KB)


#8

Figured it out. Exploded the Group, then regrouped it. Problem solved. SMH. Well, sort of. The exported STL is not correct. I’m not brave enough to save it and reopen it yet.

Solved by running Cleanup3 which removed 3 edges. SMH again.


#9

I assume the file you shared is after the validity check and fix? It appears to have lost a lot of faces compared to your first image. Unfortunately, without being able to see the original pre-fixup, I don’t know why. I do see that you have drawn at a large size, so that shouldn’t be the issue…unless you originally drew it small and then scaled up?


#10

All I did was save the file. That is the result. Exploding the group and regrouping, running Cleanup3, then exploding the group and regrouping, running Cleanup3 again and it is correct (STL). I still haven’t saved it yet.


#12

What do you get with my fixed up verison?
Untitled (1).skp (177.1 KB)


#13

@DaveR I get a boatload of validity check errors about bad persistent ids when I open your file. But it claims to fix all of them and the model at least appears to be ok.


#14

I figured that would happen which is why I uploaded it before running the Validity Check so Mr Fat can check to see what he gets.

After running the validity check:
Untitled (1).skp (173.1 KB)

Interesting slight file size reduction.


#15

I started with an STL and made some changes, apparently, that must have caused the issues. It failed the validity check on save on my machine.


#16

Thanks Guys.


#17

It was drawn at a small size and scaled up. And I am once again encountering the issue and cannot resolve it.


#18

Your file seems to work. How do you run Validity Check?


#19

Model Info>Statistics>Fix Problems.