Validity Check Errors

2017
stl
export
validitycheck

#1

I have made a model for an animatronic skull. I started with a fairly realistic actual size model of a human skull. I sliced it info two parts and kept the mandible separate. Then I reshaped the inside and made some minor adjustments to the outside so that everything I need to put inside it would fit. I changed the eye sockets, added screw holes and tabs that keep the two parts aligned and hold them together and other changes here and there. I have gone through many revisions saving each one as an stl file and 3D printing it to test them and see if I need further revisions. It has all been working fine until my latest revision. I wasn’t doing anything new, just tweaking the inside a bit getting rid of extra material left over from the anatomically correct interior that was getting in the way of some of the mechanisms I have on the inside. Same kind of stuff I’d been doing all along. This time when I tried to save it, I got a Validity Check error. I will copy and paste the entire error message here. I have no idea what it means or what I have to do to fix it. I hope someone can help me figure it out.

SketchUp STL Exporter:
An error occured during export.

undefined method -' for nil:NilClass C:/Users/Bob/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/sketchup-stl/exporter.rb:222:inget_vertex_order’
C:/Users/Bob/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/sketchup-stl/exporter.rb:123:in write_face_binary' C:/Users/Bob/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/sketchup-stl/exporter.rb:98:incall’
C:/Users/Bob/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/sketchup-stl/exporter.rb:98:in write_face' C:/Users/Bob/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/sketchup-stl/exporter.rb:76:inblock in find_faces’
C:/Users/Bob/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/sketchup-stl/exporter.rb:73:in each' C:/Users/Bob/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/sketchup-stl/exporter.rb:73:infind_faces’
C:/Users/Bob/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/sketchup-stl/exporter.rb:68:in export' C:/Users/Bob/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/sketchup-stl/exporter.rb:337:inblock in do_options’
C:/Users/Bob/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/sketchup-stl/SKUI/events.rb:82:in call' C:/Users/Bob/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/sketchup-stl/SKUI/events.rb:82:inblock in trigger_event’
C:/Users/Bob/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/sketchup-stl/SKUI/events.rb:78:in each' C:/Users/Bob/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/sketchup-stl/SKUI/events.rb:78:intrigger_event’
C:/Users/Bob/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/sketchup-stl/SKUI/window.rb:357:in event_control_callback' C:/Users/Bob/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/sketchup-stl/SKUI/window.rb:311:incallback_handler’
C:/Users/Bob/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/sketchup-stl/SKUI/window.rb:269:in block in add_callback' C:/Users/Bob/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/sketchup-stl/SKUI/window.rb:203:incall’
C:/Users/Bob/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/sketchup-stl/SKUI/window.rb:203:in show_modal' C:/Users/Bob/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/sketchup-stl/SKUI/window.rb:203:inshow’
C:/Users/Bob/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/sketchup-stl/exporter.rb:358:in do_options' C:/Users/Bob/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/sketchup-stl/exporter.rb:371:inmain’
C:/Users/Bob/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/sketchup-stl/exporter.rb:391:in block in <module:Exporter>' SketchUp:1:incall’

That was the whole message. I have successfully saved other stl files before and since this one, so the problem is something specific to this particular file. I am happy to share the file with the group if it will help.

Also, I got the error and tried some cleanup tools called CleanUp3 from the extension Warehouse. I applied most of them, but didn’t run the entire Clean program as it said it would take over 777 hours to complete.

Any help is greatly appreciated.


#2

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.