User Interface Error Applying textures from material collection of .SKM files originating from PC SketchUp for Mac SketchUp

I’ve tried numerous locations to place a Materials collections library folder containing .skm files created on a PC for visualization purposes. I would like to share this library with the rest of my studio that are MAC based. I’ve tried to place this collection on various places: our Google Shared Drive, our networked server and even locally in User Documents as well as the default location where all texture collections that ship with SketchUp live:

/Applications/SketchUp 2020/SketchUp.app/Contents/Resources/Content/Materials

However, the same application error occurs in all locations: the paint bucket will only take the first .skm selected and all subsequent materials, even though loaded correctly, are not always picked up by the paint bucket operation and often revert back to the 1st material selected.

From this strange behaviour, I deduce/speculate that it may have to do with the origination of the .skm files from PC that are not being fully translated for MAC sketchup?

Unfortunately. I think I will have to share our SKP materials collections in a more primitive way, ie, perhaps with a common .skp file with cubes of materials applied. I wanted to reach out here to see if anyone else have experienced this behaviour and have found a solution before giving in to this last resort.

Thank you,
Julie Hsieh

What version of MacOs and SketchUp are you using exactly?

As noted in the Release Notes for version 2017, the proper place where SketchUp will automatically enumerate custom materials is:

"Users/<username>/Library/Application Support/SketchUp 2017/SketchUp/Materials"

Change the version number in the path to the version you are using.

Ensure that your custom collections are within subfolders of the user "Materials" folder. (Do not place SKM files directly in the "Materials" folder.)

When SketchUp starts up it will enumerate the SKM files in this folder and the custom collections (by subfolder name) will become listed in the Materials inspector panel.


REF: SketchUp Application Release Notes - 2017 : Standardized Product Content Locations

The User Guide is somewhat terse in it’s explaination about custom material collections:

Hi Dan,

Thank you for taking the time to respond to my query:

I failed to mention that I did read your reply on another related thread. Prior to trying to place the collection into this folder:

/Applications/SketchUp 2020/SketchUp.app/Contents/Resources/Content/Materials

I had also tried placing my collection subfolder into this folder:

Users//Library/Application Support/SketchUp 2022/SketchUp/Materials

Yes, I understand how the sub-folder is recognized as a volume and for the above, my collection is contained within a sub-folder named MYCompanyName_SketchUp_Materials-V1

The collection actually loads into the Mac SketchUp color editor, and I see all the thumbnails. I want to be clear that the problem isn’t that I cannot find my collection, the problem is that everything loads correctly, but the paint bucket operation only picks up the first material on assignment. All subsequent materials do not work when selected, even when the dialogue shows them loaded and selected. While on a different material, the paint bucket will still assign the first material picked.

I have replicated this problem on another Mac in the studio. If you have access to a PC and a Mac, you might be able to replicate the same User Interface problem. I tried creating some materials from a Mac to add to a new collection, and these .skm files did not present the same problem when I access the collection and use the bucket tool to assign the materials. This is the reason why I deduced that the problem maybe the .skm files themselves.

I am using SketchUp Pro 2022 for both PC and Mac.

I do not have a Mac to test myself. I recall some other issues with resources recently on the Mac.

ping @colin

FYI: SKM files are actually zip archives containing XML data files and resources (such as image files.)

I did a quick test where I copied the Tiles folder from inside /Applications/SketchUp 2022/SketchUp.app/Contents/Resources/Content/Materials and pasted it in ~/Library/Application Support/SketchUp 2022/SketchUp/Materials, and renamed it.

2022 then saw the new entry, and any material I choose does paint ok.

Colin, I have noticed that zip archives created on Mac have a weird _MACOS (or similar) named file within them.
Would the lack of such a file in the archive cause an issue for the Mac editions reading SKMs created on Windows platform?

Hello Colin, thank you for investigating,

Do you have access to both PC and Mac and able to copy over .skm files created via PC SketchUp and deploy over on Mac SketchUp, version 2022 preferably and see if you are able to replicate the same issue I am encountering: ie. the UI not behaving as it is expected to when cycling through the different textures when in paint bucket mode?

Julie

I don’t think it should matter.

1 Like

I will try a similar test, and even go via a zip file, see if my OC materials still function on Mac.

Thank you Colin. Appreciate it.

To complicate matters, when I created my library on the PC as aforementioned it was for visualization purposes and it involved Enscape’s material editor ie. the .skm files would have other supporting textures as its dependencies/resources.

If you do not encounter the same issues, then it could be because Enscape material editor was involved. However, I do not understand how the additional metadata would matter because isn’t it only the albedo texture files that SketchUp need for texture assignment and they all loaded as thumbnails perfectly anyways.

Julie

I did the same steps from Windows. I copied one of the shipped material folders, paste it in Downloads, zip compressed it, copied it to my Mac, put it into the Mac support folder and renamed the folder. The materials worked ok in SketchUp 2022 on Mac.

Thank you Colin,

I will try the same test tomorrow. With an existing shipped SketchUp collection library. To see how this works vs. the ones I’ve made myself. Just to be sure we are on the same page.

I will also try to make a library without Enscape (ie. all the additional textures.) To see how that works, if that also work, then I will know it is Enscape.

I will circle back with my findings.

Julie

Hi Colin,

I did a test creating two separate material libraries,

1: Albedo texture only
2: Enscape with a bump texture added.

It would appear that the ones with Albedo texture only added in the SketchUp Texture Editor on PC worked ok on Mac. I didn’t even have to drag to any folder. It was working off of a Shared Google Drive location.

The materials with Enscape that has added bump texture for example, exhibited the same behaviour anomaly when paint bucket is assigned.

So it seems this a problem with .skm files created via Enscape as I speculated after your test.

Thank you so much for testing for me. I guess I will reach out to Enscape support and see what they might advise. Enscape was only very recently introduced to Mac so I have a feeling they don’t have everything figured out yet.

Best,
Julie

Would it be possible to try an example file? I have ideas on ways to make SketchUp cope better with their files.

Yes. Of course, by trying example files I assume you mean like if I send you some .skm files that were created on my PC with Enscape?

I have attached below a folder containing 3 .skm files created with Enscape on PC SketchUp each has an additional supporting bump texture.

Test_Enscape.zip (693.4 KB)

That should be irrelevant. The main content of the zip should be the same.

1 Like

Yes, that’s all I meant. I will show the files to colleagues, and talk about the idea I have in mind.

Do you have any that include bump maps? Or do the ones you gave me have those already?

Hi Colin, yes the attached .skm files have the bump channel in the Enscape Material Editor assigned with textures.