Upgrade from go to pro

Hi everbody,

I’ve just bought for 131.89 € the GO version of Sketchup by mistake. I’d like to upgrade it to the PRO version, but end up to a dead-end page.

How can I do that? Is it possible? The way the sketchup help notice indicates is of no use. As i said, it leads me to a page that tells me "You are not authorized to access this page. "

Thank you a lot for your help!

I see that error too, I will report the problem.

Meanwhile, here’s an article that shows the steps for what you are trying to do:

Thanks Colin for the quick response.
For the time being, I can work with the Go version, but it’s not as smooth and practical as the Pro one. I hope the Sketchup team will be able to solve the issue within a reasonable delay. Keep me updated if you can. Cheers!

The link I gave is to an article that works. You should be able to upgrade to Pro before the help pages are fixed.

Unless you’re saying that you followed the steps in the article I gave, and still it fails? That would be a more serious issue.

Hello,

No, I haven’t yet tried the link you gave. I’ll see to that today. Thanks again!

The help page link problem is fixed by the way.

Great news! Thanks for the good job you’re doing!

hello,

I’m sorry it took so long for me to try again the step-by-step help menu of Sketchup, but I was on vacation and wasn’t in the best of mood to spend time on this.

So, today, I tried again, and the issue remains: “access denied”.

I did bought GO and want to upgrade to PRO. The Help page says it’s possible and “it takes on a few minutes”.

"If you purchased Go by accident and really want the Pro plan, the good news is that there’s no need to request a refund for Go. You can easily upgrade to Pro in the Account Management Portal (AMP) and just pay the difference in the prorated price. It only takes a few minutes, and here’s how! (read all 5 steps before doing them)

1. Go to this Account Management article."

At this point, I can’t proceed to step 2 as the page step 1 is bringing me to is a dead end…

help, please!

I also see the “Access Denied” message for this Help article.

Jody fixed the link on the original article, but it seems the same bad link is on this other article. I let him know.

1 Like

This topic was automatically closed after 186 days. New replies are no longer allowed.