`Unwanted copies in Adobe Acrobat Document

Hello trouble shooters
Me problem is that Sketchup files are also unwanted copied` in Adobe Acrobat Document files .skb.
Consumung alot memery so the “C” and also the “D” ( second adres for SU) are almost full.
What could be the cause of it.

.skp are SketchUp Model files, .skb are backup files.
SketchUp creates a backup upon opening a file.
If you do not wish that, you can uncheck this behavior in Window>Preferences>General

Somehow, windows sees your backup file(.skb as an Adobe file.

Every time you edit and then save a .skp file, SketchUp creates a backup .skb file by renaming the pre-edit version. So, it is completely normal to see two files for each model, the current version .skp and the backup version .skb (note: on Mac the backup is named following the UNIX convention of appending a '~" to the base part of the filename but keeping the .skp extension). If you feel the current version is ok, you can safely delete the backups to save space. As @MikeWayzovski wrote, you can also tell SketchUp not to create backups via Preferences->General if you feel safe with the risk you might lose the entire file in case of a crash.

As to the system association that .skb files are Acrobat files, this is a mistake that I have also seen (several years ago when I was running Windows 7). Somehow Windows had become convinced that .skb files belong to Acrobat. The fix is to tell Windows the right association. I think you do that by right-click on any of the .skb files, but I have switched to Mac and I have forgotten the details of the right process.

1 Like

Steeve Thanks for the info.
Mine experience with those files are when the skp file is deleted the bu
wil not start in SU you have to change the extension in skp.
I will change the preference in SU.
Q. I can’t remember how to delete multiple files with skb in one time from a file. Do you know? Q. %?.skb%.

Select the SKB files and hit Delete. Hold Ctrl while you select them one at a time or if you have them sorted together, select the first one and hold Shift while selecting the last one. Hit Delete.

Why are you so set on deleting the SKB files? Eliminating them eliminates the backup if something happens to corrupt the SKP file.

Windows regards foo.skp and foo.skb as completely independent files. Deleting the .skp will not cause Windows to also delete the .skb or to rename it to .skp; you have to select both. If you forget, this can lead to accumulation of stale .skb files with no matching .skp.

Regarding opening the .skb files, you have two choices: you can rename the file to a .skp or you can modify the Windows settings so that it opens .skb with SketchUp instead of Acrobat. My recollection from when I ran Windows is that changing the association increased the chance that I would accidentally open the backup .skb instead of the latest .skp and panic that I had lost my edits!

This problem came up when I need same space for a iPad backup because of iCloud not working for pictures satis. I will delete them.
Thanks for help.

As a point of interest, here are all of the file types used in connection with Acrobat:


None are .skb. Also, here’s another time it happened to someone with SketchUp:


1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.