Uninstalling Separately Downloaded Plugins


#1

Hello All -

Before I begin, I must say that I spent a night researching and scouring the forums for this problem. I’ve come up empty.

This is the issue. Weeks ago, I download the V-ray trial version plugin and found it to be pretty troublesome. (crashing sketchup, not rendering certain surfaces, lights not working, etc.) I then tried installing SUPodium which was blocked by my antivirus software and could not render. I now am searching for a better renderer but before I do anything I’d like to get rid of the other two.

When I go into the extension manager, I cannot uninstall these plugins. When I hit the “uninstall” button, a grey message appears below the plugin saying that I do not have permission to uninstall it. The plugins I want to delete also do not show up in the extension warehouse under “my extensions”.

I’ve deleted all associated files and information (that I could find) from my Mac HD and yet the plugins still appear in sketchup. How on earth do you get rid of these things?

Cheers


#2

Because you didn’t install them from the extension warehouse, there is a more manual process. Especially for vray, where you have to hunt down a series of support files and toss them.


#3

I gathered as much. I run sketchup make 2017. What would that more manual process be?


#4

Just for the record, with the specifications stated in your profile, I would not bother to use/test the latest version of render plugins at all

Use kubity:

https://kubity.com/

It renders for you and you can get walkthroughs ( by SketchUp scenes) and Augmented views as well as Virtual reality (cardboard or HTC-Vive)


Rendering Misery/Suggestions for V-ray?
#5

For Su-Podium:

http://suplugins.com/podium/help/uninstall-mac.php

For V-Ray:

https://docs.chaosgroup.com/display/VRAYSKETCHUP/Uninstall+V-Ray


#6

Note: the message you got is because these extensions install in folders for which ordinary users don’t have write permission. You need a certain level of system knowledge to work around this, and also you have to know or figure out where all the extension has installed files. Because these don’t use the standard SketchUp Extension Manager to install, the files could be just about anywhere. Using the techniques @MikeWayzovski linked is much safer than attempting the manual process.


#7

Thanks for the info - I will try the chaos group one. Think I trashed every file related to it but the stuff still shows. As for podium, The uninstaller was also being blocked by antivirus software and won’t run. argh!


#8

You should be able to suspend the antivirus while the uninstaller runs? That blocking is further evidence that the extension puts files in places that are considered “unsafe” by the A/V.


#9

I think the v ray uninstaller was deleted in my quest to get rid of everything related to v ray. :expressionless:


#10

Perhaps it is still in the Trash.
Or reinstall V-Ray etc.

disable the antivirus software?

Have you tried Kubity, yet?


#11

I’ll see if I can download the v ray uninstaller. Have not tried Kubity - does it have the capabilities of v ray? (lighting, grass/carpet textures, etc.)


#12

I was refering to the capabilities of your system, when I mentioned Kubity.
Render developers generally are always a bit ‘fussy’ when it comes to minimum requirements for their software, and if you do not meet the minimum requirements of SketchUp, well then, ehm, you might want to use a render program that does not take any resources from your machine besides the internet connection to their servers.

It all adds up. V-Ray is CUDA based, which Apple has not implemented in their Macs.
SU-Podium tends to work better on a Mac, but also has min. requirements. Not sure why it fails to work on your machine.