Unexpected file format pleaseee

Hey! I really need help.
I tried opening a file and the “Unexpected File Formart” error appears, I tried to change the file name and format, but i can´t open it…

Where have you saved the file that you are trying to open? Have you saved anything to Trimble? Can you attach a skp or skb file in a reply to this comment? If you give more information, someone should be able to help you.

1 Like

You will surely be helped by anyone on this forum but without the file it’s going to be impossible to know what’s the issue. If the file is corrupted there’s a chance that @colin can recover everything or at least part of it if it’s not filled with zeros.

If you were working on a file on the cloud or in an external device like a usb memory, external storage or server you are playing with fire, there’s a high probability to corrupt a file that way. There are people that have done that for a long time and never had any issues but it’s like russian roulette at some point you will run out of luck.

1 Like

Can you put the file online somewhere so we can try to recover it? You can use a web site such as wetransfer.com to upload the file. Note that you don’t have to sign up with wetransfer in order to send a file. Also, when you have dragged your file onto the browser window, click on the blue dots to change the settings from needing an email address, to getting a link. Then reply here with the link you are given.

1 Like

Yeah, I got “this does not appear to be a SketchUp model.” Maybe @Colin can help.

I did try to rescue something from the file, but wasn’t able to get anything.

1 Like


This topic was automatically closed after 186 days. New replies are no longer allowed.