Unexpected file format - please help

Hello, I have been working on a file for many days now, I saved the work today and have tried to reopen it and now its showing unexpected fille format. I have tried to do the fixes, ive read in the forum, changing suffix etc… Can someone help me?

Not unless you share the .skp file.

What operating system? Windows or Mac? 2023 is not the answer to that question in your forum profile.

Windows operating system.

It says the file is too big to upload

Uppload it to DropBox and share the link.

There was a bad component and a bad group in the file. I couldn’t identify which ones. I did note quite a lot of incorrect tag usage which I fixed.
Screenshot - 8_17_2023 , 4_25_40 PM

And I purged a bunch of unused stuff which reduced the file by about a third.
Screenshot - 8_17_2023 , 4_26_01 PM

There is still a bunch of stuff you could clean up. Components that can be lightened. I set the face style to Monochrome so you can see reversed faces that need to be fixed. You should see no blue back faces in your model.

See if this works for you.

Thank you very much! I am new to sketch up and just learning so I think there are lots of mistakes. The file opens now but is locked by you.

No. It can’t be locked by me. There is no way to lock a SketchUp file.

Quit all instances of SketchUp running on your computer. Then try opening the file. Make sure you are downloading the file to your computer first.

Maybe you have opened another instance of the file, so you’ll get the message that it’s only reading file, close all the instances and windows of sketchup and open again the file.