Unexpected File Format - HELP! - Mac to PC maybe?

sketchup
windows10
unexpectedfileformat

#1

Hi there

I created a sketchup file a couple of years ago on different computer and in a different version of SketchUp. I would now like to return to the project, however when I try to open the file I get an “unexpected file format” error.

It was orginally created on a mac and I’m now trying to open on a PC. I know this usually isn’t an issue, but just thought I’d put all the parameters out there in case.

Desperately hoping there is a way I will be able to open it. One of the files (which must be the mac backup file) even shows a thumbnail of my project, so I’m hoping that means its still there somewhere!

Thank you for any advice you can give.

Katy :slight_smile:


#2

If you upload it here someone could try and open it. The files are interchangeable between Mac and Windows, so that shouldn’t be an issue. It may just be corrupted.


#3

Have you tried renaming the backup file and opening that? It might work.

This unexpected file format thing used to happen to me with earlier versions of SketchUp. Haven’t seen it in five or six years, though. One thing I found by accident that helped was to e-mail the file to myself. You might try that.


#4

That would be great! Unfortunately the file size is too large - its 23mb. Is there another way you would suggest is safe to share it?


#5

Hey Dave!

I tried emailing it to myself as suggested…and for a moment I thought I was in for a win! Unfortunately though when it opened the file was empty. I also noticed after that it said the attachment file size was only 143 bytes and not the 23mb the original file size was.


#6

Well, that would certainly be a problem. Unfortunately it may be that the file is corrupted. If you look at your Sent folder, how big is the attachment?


#7

Actually I just tried emailing it to myself again and this time it said the file was too big…which is a good sign because at least its still 23mb!


#8

Here is a link to the files on dropbox…


#9

Unfortunately I get the same Unexpected File Format on both. It may be that the files are just plain old corrupted. Do you have anything else from this project? A LayOut file, perhaps?


#10

No unfortunately that’s it. Sounds like I need to come to terms with the fact they’re gone!

Thank you so much for trying to help - I really appreciate it.


#11

I wish it had been successful.

Can you reconstruct the model?

I did some more reading on this error and found a thread in which @bugra was able to recover a file for another user. See this thread: The Dreaded - Unexpected file format

Your profile says you use SketchUp Make so I don’t know if they would do anything for you or if the issue is the even the same but…


#12

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.