Undo paint bucket causes Bugsplat


#1

Hello everyone.

I have a particular problem in SU 2015 and normally, before I decide to just ask something on forum, I do quite the research as surely I’m not the only one with SU problem. After whole day of researching the web and reading topics I am clueles to what causes Bugsplat on my computer.

I recently installed Vray 2.0 for SU 2015. I did some test renders it works fine, well everything works fine except when I apply material (via Paint bucket) from Materials’ library on face and then click Undo in Edit menu. SU then crashes and leaves me with bugsplat report. It doesn’t do it if I apply colors from Materials but does it with all other textures and materials (I tested it with bricks, groundcover, asphalt, blinds etc.) If I disable Vray via Ruby console or uninstall it, the problem’s gone. It doesn’t crash if I, after applying material, draw some lines. In this case I can Undo everything including Paint bucket. It happens only if my last action is paint bucket and then if I undo it. I suspect that Vray is in some way altering the material attributes?

I already tried some of the solutions and none of them worked: I tried to disable hardware accleration and disable Auto - save. Also tried running as administrator, repair install sketchup. I am also sure that all my drivers are up to date.

I work on a laptop: 64 bit OS; Windows 8.1; Intel core i7 4700HQ; 2,40 GHz; 8GB RAM; Geforce GT 750M

I’m looking forward to finding solution on fixing this problem.

Regards,

Domen


#2

Does Vray have a forum of it’s own ? If so, check there if this bug has been reported. IF not, pls report it to Vray.


#3

Did you submit these BugSplats? If you did - did you enter any details I can use to look them up?


#4

@DanRathbun Vray indeed has a forum on it’s own and I already checked it. The bug hasn’t beed reported so I’ll report it to Vray then.

@tt_su I in fact submitted just one BugSplat, that was when I ran out of options/possible solutions. I also described what happened, similar to my first post. In can reproduce the BugSplat so am going to do it now also with some details so it should be easier for you to find it.


#5

I sent some BugSplat reports. I once again checked and SU also crashes even if I after applying material draw some lines and then undo the whole thing.

Bugsplat reports numbers are #149235 and #149237 if that helps.


#6

Thank you very much. I was able to locate the crashes. I have a suspicion what might be going on on our side. I’ll file an issue for that.

But be sure to report this issue to ChaosGroup as well, as they should be able to work around it. I think the issue is that modifications are made to the material from the library before it’s added to the model. When you undo SU tried to revert those but crash because undo require the material to belong to a model. Extensions can work around this by checking the owner of the material before they use it.


#7

I used to experience such an event, namely crash or bug splat at the time of rendering caused by the coloring material. and investigate calibaration proved too many temp files located in a hidden directory - Users> name of the computer (unhide)> AppData> Local> Temp. Open this folder then clean all the junk files, if that can not be disposed skip. reopen SketchUp and start working again.
If this is still the case should create a separate folder for placing material coloring bitmap images.
Hope it is useful