Underneath component selected when clicking component on top

I’m modelling a carport with plywood sheathing roof and solar panels on top. With the model in the orientation shown in the attached model, if I try to select the rightmost solar panel (white) by clicking in the middle, the plywood sheathing underneath is selected rather than the solar panel. Same applies to the leftmost solar panel. In the current orientation, the center panel is selectable.
To reproduce the problem, click on the roof, Edit Component and then try to select each solar panel. Change the orientation and the outside panels can be selected.
What’s going on? I’m using Sketchup Go (Web).
Note that I’m not sure if the problem is reproduced in the desktop version, but I used the “Open from Device” feature of Sketchup Go (web) to import the attached .skp file and the problem reproduces in that model.
Thanks in advance.
Carport V2.3.2.skp (543.9 KB)

If I double click on your roof to open it for editing, I can select any of the solar panels and any of the roof panels without any problem.

BTW, I suggest that you do your modelling in perspective camera mode.

What you describe could be caused by having the camera set to Parallel Projection. As Jean indicated you should do your modeling with the Camera set to Perspective. Save Parallel Projection for output views.

I don’t get it, I’ve been working mostly in parallel projection for the past 15 years, haven’t got any issue. it reduces geometry issues, things are correctly parallel to each other. sure, in tight spaces there is no choice, but to me, it’s perspective that has to be switched to just for output :slight_smile:
The idea of having to design only in perspective makes my skin crawl…
And in this file, I can’t reproduce the issue on pro, both PC and mac. All panel are normally selectable. Might be a web (go) thing ? Browser up to date ?

I’m using Chrome browser, (apparently up-to-date) at version Version 110.0.5481.178 (Official Build) (64-bit). I tried using Edge and, as you all report, everything works as expected. Has anyone tried to repro using Chrome?
Is this likely something I should report as a bug?

I just tried on firefox, it also runs as supposed to. Unless I misunderstood the issue.

You’re too far. while posting, I just tried zooming out a bit (on GO) and when you move out a bit, the plywood selects. I suspect zoom Z fighting, since your panels are quite thin.
The issue is there in both perspective and parallel, same way, if you zoom out a bit, then since your panels are quite thin, SU selects the plywood instead.

And now that I know what to look for, it’s the same on PRO, both perspective and parallel. Not with your current zoom, but when I zoom out a bit, there goes the Z fighting.

Many thanks. I’m finding the same. If I zoom out I get the problem, if I zoom in, problem goes away, both Chrome and Edge. Is this something that should be reported to Sketchup as a bug or is this a known “feature”?

It is known :dragon:

Yeah, you’re working from too far. When too far, SU has trouble deciding what you’re clicking. a thin slab becomes almost like a single face, and stuff underneath starts bleeding out. If you design something with thin elements, you’ll experience it often

Here is a video of Aaron talking about it in detail
Second part, the bleed through issue. And when you’re too far, SU will grab the elements bleeding through instead of the top ones

It’s a thing I keep repeating in almost every class, “zooming in and out is free. please use your wheel”. I see (too eften) people designing stuff on a tiny area the size of a passport while on a 23"+ screen. Zoom in, take the space on your screen. it’s here for that :wink:

Many thanks. I was zoomed out because I wanted to hide multiple panels at the same time. But I will take your advice. The video is very useful and made me realize that, in fact, to correctly model my solar panels, they should be on short legs. Haven’t done this yet, but I think that will solve the problem.

Thanks again.