Unable to start SketchUp

Sorry, I haven’t used SketchUp for a while. I’m using SketchUp Make v.17.3 on a Mac computer with High Sierra 10.13.1. When I try to open a file I get a bugsplat before the file opens, and a message “SketchUp cannot start due to license error.” I’m working on a fairly big file (49MB) but it’s been fine until today. I get the same message when I try to open small files.

Are you sure you installed Make when you installed SU2017.3.xxxx? Is it possible you installed SU 2017 Pro and your 30-day trial has expired?

You might have a point. I installed 2017 SketchUp about a month ago, and I thought there was a free trial of Pro that would just phase out in 30 days if you didn’t choose to purchase it. I’ll try reinstalling Make and see if that resolves the issue. Thanks very much, it’s so nice to get a prompt response.

If you installed the Pro version it would not open after the 30-day trial. If you’d installed the Make version, if would start as Pro for 30 days and then revert to Make if you don’t add the license.

Where would I go to download the latest version of SketchUp Make for a Mac? I only seem to find Windows downloads.


Thanks for the site info. I downloaded SketchUp Make for the Mac, but it still will not open. I get the same message. “SketchUp cannot start due to license error” also I get bugsplat.

Try uninstalling SketchUp 2017, first.

I put the old folder in trash, restarted the computer, reinstalled SketdhUp, and I still get the same license error message. I’m not sure if “uninstalling” requires more than just trashing the old folder.

1 Like

You have to also trash the Sketchup 2017 file in User/Library/Application Support… it holds the license files. Then try a System restart before re-installing.

Sorry to confuse the forum. Am unused to using it. I was finally able to open SU 2017 Make by reinstalling it after trashing all of the sketchup .plist files along with the google sketchup .plist files. What a relief, thanks for your advice.

Glad you managed to finally get it sorted. I know how frustrating that kind of ordeal can be.

I’ve put thousands of hours into 3D models in SketchUp Make. I have the 2017 version on a Mac Computer. It will not open now due to a license error? I don’t have a license. I’ve reinstalled the file but always get the message “SketchUp cannot start due to license error.” How can I access my very extensive work?

I am not a strong Mac user, so I will let others who are, help you out. But This is a case where, if you have to just access and view them, SketchUp Free should work just fine.


You can also re-download a fresh copy of SU Make 2017 to resolve your license issues — it’s still available, just not being updated.

spend a minute filling in your profile…

are you still on Yosemite for example?


I’ve already re-downloaded a fresh copy of SU Make 2017 and I still get the same license message and cannot open my files. I also went into the library and jettisoned all of my old .plist stuff.

No, I’m in High Sierra.

SketchUp free will not open my files. They are greyed out.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.