Unable to sign in - can't manage activations

I have a trial version of studio. I was using Sketchup pro this morning. Had a model open but made a mess of it so decided to open a new file. A new file would not open. So i closed SketchUp and tried to open it again fresh.

Now I get a box telling me “Please Authorize Sketchup”

It tells me I am using Sketchup Pro on too many machines.

This is really odd because I only have one machine! I tried following the help guide posted to a similar issue several posts down from this one with a similar issue. However since I am using a trial version there is no help offered because of this…

" If you see this message, click on Manage Activations and sign into your Trimble Account management page. Navigate to the My Products menu item and look for SketchUp Pro or Studio (not the Trial or Free one)."

Since I have the trial I dont know where to go next.

Any ideas from anyone here?


That would be the same webpage, the trial is not a ‘special’ version of SketchUp, everyone uses the same (Students, commercial and ‘trialers’ like yourself)

Btw. apart from the OS, offcourse

You login with a Trimble ID and then it checks to see what products you get to use.

This depends on the plan you have (eg. Shop-Pro-Studio-etc)

Every plan is assigned to an account, and you can have more than one.

The trials are assigned to your ‘personal account’

The included apps should be there, too.

Yes - I log in with my Trimble ID. It goes to my Trimble account page. I click on my products and I see Sketchup free and Sketchup studio trial.

When I view included applications under Studio, I see a long list of apps. Sketchup Pro is there.

I have Sketchup Pro installed on my PC.

I downloaded the installer package and ran it again and selected repair. It did nothing to help. I still cant get Sketchup pro to open as I get the same message - signed into too many machines.

This is really odd.

OK got it. Found the right place - bit convoluted if you are not familiar with Trimble.

Not to worry, back in, thanks.

Thanks for being persistent and finding the right manage devices link. Previously the manage devices option was one level up from where you found it, but that had the drawback of deauthorizing your mobile devices when all you were trying to do was fix the desktop devices. Now you can deauthorize for a specific included application.

If you are trying SketchUp 2021 at the moment, and you still have 2019 or 2020 installed, it would be worth opening them briefly, and making sure that you are signed out. Each version’s sign in counts, and you could get into the situation you saw because of not having signed out of an older version.

Something to know, if you do see the same thing again, where you can’t start a new document or open an old one, the deauthorizing or signing out of other versions can all happen without having to quit SketchUp. As an example case, after you had done the deauthorize all devices, your second computer may have been still working on something in SketchUp, and now it would start to see that message. Just sign out, and sign in again, and it gets a fresh start as one of your authorized devices.