Unable to fill the gap in the curved face

Hi everybody,

There is little square in the lower corner was created automatically when the curve was drawn. Now, I try to remove this square so when apply edge smoothing will not interrupt the model. What I did, removed the square and then found that the entire curved face was removed. Finally, i placed a straight line to connect both edges of the previous curve, but still the gap is not completely filled. I do believe that might be a non-coplanner geometry is taking place, but no idea how to fix this little problem. I look forward for your help and support and explanation of how to control this scenario in the future.

Images and model is attached with the message.

Ali rounding corners.skp (1.2 MB)

You cannot delete the two lines because the faces are not coplanar. If you have a close look, you can see the different orientations of the faces…

A fast “repair” would be to use CTRL+eraser, otherwise you have to scale up that model before you can try to repair it with the move tool.

1 Like

You can change the edgle color to “by axis” to see which lines are not aligned to the global coordinate system.

1 Like

Yes, I realized now very closely that both faces are not coplanar and will use the move tool to modify it. In face, I used CTRL+eraser but the whole curve was removed.

Appreciating your nice hints and comments.


What’s really odd is that while scaled up, you can push pull the clearly non planar face. There are some errors in the model that can be exposed by using “fix model” in the model info window. I’m not sure if fixing is the best course of action though.


No. But it will probably be worse in the long run not to repair it… :wink:

Color by Axes can be very misleading.
It has a very broad tolerance to off-axes geometry.
It’s nowhere near accurate enough to detect geometry off-axes in such small increments.

Here, the Query Tool is your best friend for investigating what’s wrong.
(We keep hoping the SU Team will put just it and Point at Center back in the download where they belong.)



Yes, but I think this is true and helps here?

  • If a line is black, it’s not parallel to an axis
  • If a line is red, green, blue, the line is parallel or nearly parallel to an axis

Here, the first point is enough to show the problem of the model.

I would say practically useless when diagnosing these types of small errors.


1 Like

Fellow Sage @Wo3Dan has pointed this out many times in the past.
Of course, Dutch Structural Engineers are known to be rather precise.
But not overly so… :wink:


Thank you Shep for your feedback… Sometimes if I apply “fix model” many components will be affected by this change which requires me to change my modeling plan again.

Thanks again for your great reply.


Actually, I found the comment from Mr. Cotty was very useful to me to just change the style of the edge display to axis by color, then I changed the model scale and used the move tool to move the vertex and finally became co-planer faces… Great job, indeed.

I will try to install the plugin (Query Tool) to check its scope of capability to create faces for all types of shapes and not only square as some users were complaining in the Plugin Page’s comments.

Appreciating your excellent reply and I hope the two mentioned tools will be included in the download page or even in the native tool bar in latest SU version.

Hey friends,

I would like to share this useful video tutorial that demo the key solution to fix the co-planer faces using two nice techniques:
1- Styles → Edit → Axes by color (Then removing the extra segment of the longer edge).
2- After deciding which edge is the longer, using the move tool to move the vertex to make it parallel to the opposite vertex by hovering the mouse on other vertex.

Enjoy watching this useful Video, click here.

Take care,

But, as suggested by @Geo and @Shep you should only use this in one direction:
- line is black, not parallel
because the other way round:
- line is colored and line is parallel
isn’t always true because of the mentioned tollerances.

Yes, I agree with you and I have tried all the possible options on the geometry… Sometimes, even though both edges are let’s say (RED) but are not parallel… may just less with 1mm (was confusing)… it will be normal with more practice. Thank you for your usual support in this forum.

Take care,

It might be useful to have a plugin wherein you click on an edge and if it were truly on axis, would change color to red, green or blue (even temporarily). This would be a bit faster than watching the coordinates in the query tool.
Make sense to anyone?


1 Like

I agree completely with you and I’m not sure if Sketchup team can consider it as strong suggestion to be enhanced in the future or one of the developers to consider it in his plan to create a new plugin.


Many of the issues are there are a number of edges which have not been intersected properly ( at wrong vertex) thus causing the intersection with the adjacent vertex causing the line to be out of plane. You can easily see this by rendering your model in wire frame and then selecting a edge and the line will not stop where expected showing a non intersection where it should be. Primarily at the gap. The area you flagged in your OP would be a good place to start to see that. Also the gaps have not been intersected properly. That is hard to see since they are so small with respect to you model. Use a section plane and it can be seen very easly and because gap is so narrow it is hard to select correct vertices unless you are very careful. You have a lots of redrawing to redo:(

Off-Axes modeling errors are pretty much the realm of new user’s inattention to Inferencing

Instant feedback from the Inference Engine tells us if we’re on-axes as we draw.
Shift and arrow key Inference Locking constrains the tool to the selected axis.

A modest programmable mouse makes inference locking a seamless, one-hand operation.