Unable to Download STL plugin

I think it’s Sketchup account problem. I signed into Sketchup using my Google account for the first time few days ago and have the same problems as you all describe - I sign in, click download, then some redirections and i get to the extension warehouse home page.

I suspect it’s a problem with account creation - when I signed in for the first time, my accounts in 3d warehouse and extension warehouse got created. When I go to account settings in extension warehouse, I change something and save, I get an error “The e-mail address xxxxxx@xxxxx.xx is already taken.”. So I can change no settings and I think the extension warehouse also rejects the account. 3D warehouse has no such problems, account looks fine.

Additionally when I go to the file URL directly, e.g. “Page Not Found | SketchUp Extension Warehouse” I get an error “You are not authorized to access this page.” so it doesn’t work as a workaround. When I go to “My Extensions” and click on the Download, it works… Is there a way how to get other extensions to this “My Extensions” page?


@andrew.bigford, thnx. warehouse still not working, but your posted .rbz worked fine with manual install.

Could someone post Solid Inspector² .rpz file too?

Maybe make a new rbz-request thread on this forum, lol. :stuck_out_tongue_winking_eye:

I have the same problem. I uninstalled, re-installed, tried 3 different browsers, tried installing from inside and outside SketchUp. From inside Sketchup I get an Authentication error message. When I access directly from the browser I am sent back to the extensions main page.

Could the Sketchbook support staff please acknowledge on this thread that they are aware of this problem.

Hi everyone, here’s a current update on this issue. We have been looking into it over the weekend and we believe we have found the root problem and we have a fix that we are getting ready to test this morning (its just after 9:00 am where I am).

Once we get the fix tested, we’ll roll it out as fast as we can. Either I, or Barry will post here to this thread once the fix is live. We’d like as many people as possible to test that it works in the real world.

Thanks for your patience,

Chris Fullmer
Extensibility Product Manager

1 Like

Thank you very much.

SketchUp uses the MSIE WebBrowser Control (even on Windows 10.) It is a Microsoft library (DLL) that applications can use to create browser frames.

If you have the paid edition of MalwareBytes, you should add “*.sketchup.com” as a “trusted site.”
Open the MalwareBytes control panel.
Click the “Settings” button on the top button bar.
Choose “Web Exclusions” from the left margin navigation list.
Click the “Add Domain” button at the bottom of the panel.
Enter “sketchup.com” (or “*.sketchup.com” if it allows wildcards.)

The rbz is available (named .zip) at it’s GitHub repository. Just rename it’s extension to .rbz and use the “Install Extension…” button on the “Extensions” panel of SketchUp’s “Preferences” dialog.

Same here, as posted before:

<<It is not still working. THis is for PC. When I click on Download it takes me to the google login page. I login. It takes me back to the page where you can click on the button to download. I do that and it logs me out of the program and sends me back to the main 3D plugin page.>>

Windows 7 64b

I am new to Sketchup and have downloaded the Make version but currently it is the trial version of the Pro version.

Not sure if that has anything to do with it but I am also experiencing the same issue where I can not download the Sketchup stl plugin (or any plugins for that matter).

Also, I have tried this on two separate PCs, one with windows 7 and one with Windows 10.

In one post I saw someone mention that if you get the install button then you are signed in but if you see the download button then you are not signed in and you are accessing it from your browser so I have been signing in and using the install button but it displays the window with a fast displayed script that logs me off and returns me to the extension warehouse.

I read in another post that someone added a plugin folder and then they were able to downlad the plugin, but was an older version of Sketchup (ver 8 I think)

Not sure if this would help but can anyone that has this working please post the folder path that their plug ins are located for Sketchup 2016?

Also, I have sent numerous requests for help with this to the Sketchup technical support but have not received a response.

If anyone can point me to a link where I can copy (save target as) to this Sketcup STL export plugin file other than the unusable extension warehouse, I would appreciate it immensely.

Also, if anyone has found a cure for this, please pass it on.


The issue is being worked on so just have patience.

Do not add a folder for plugins. there’s no need for that.

Thanks for the update on this DaveR.
Please keep us posted on updates on the resolution of this issue.

The SketchUp team have been doing that. Just read the thread and several others that have been started.

One thing I should point out on all threads - you can still create an STL, in fact, typically a nicer STL with support structure added as needed to 3D print, using 3DWarehouse. See 3D warehouse signin problems

It works for me now.
Thankyou both for help and sketchup. :tada:

1 Like

Thank you very much! I love SketchUp!

1 Like

Update: As noted by ss1 and DFrost above (Thanks!), we got the fix rolled out onto our public servers about an hour ago. Please let us know here if anyone continues to experience problems.

I believe the final diagnosis was that we were having problems with the Terms of Service agreement system. People who had not agreed to the TOS (new users) or people who needed to agree to the most recent TOS were being blocked from downloading and experiencing other oddities, but were not being presented with the little window asking them to agree to the Terms of Service. We got the TOS agreement system back up and running smoothly. I think everyone who was blocked will be prompted to agree to the Terms of Service, then they will be able to proceed on to the download.

Thanks for your patience and help in troubleshooting this nasty issue.

Chris Fullmer


I was able to successfully install today.

  1. In Windows 10, right-click on SketchUp icon and choose ‘Run as Administrator’. (Note that it doesn’t matter that I was already logged in as one.)
  2. In SketchUp, go to Window->Extension Warehouse.
  3. Choose the STL extension, then click on Download.

It made me login, then accept T&C, click Download or Install a couple more times and finally gave a warning, but after ALL THAT, the File->Export STL menu option is there and working now.


@Barry I am using sketchUp pro 8 and I already download the stl extension and when I go to sketchUp to manually download the .rbz file like what the instruction says, so I go to windows-preferences- and select extension, on the extension pane it doesnt show any “Install Extension” option. So how can I install this extension file? Thanks

@v2giancdoria, the “Install Extension” button was added in SketchUp 8 MR1, so you must have only the original release. (There were 5 maintenance releases since then.)

See: SketchUp Help: Installing extensions manually in SketchUp

This image is from SketchUp (8MR5) v 8.0.16846:

Working perfectly now!
Thanks sketchup team!

We’ve finally been able to reproduce failure to login 3DW and EW on Windows SketchUp only, and with an intern who’s University has a login shim that pops up immediately after the Google OAuth login page that makes him login to his University account as well. The lower left login/logout is his only option, so hopefully we’ll be able to fix this with a case we can reproduce in house.