Ultimaker Cura Not accepting File

My student used the follow me tool to create hooks. Cura found that the circle from where the hook begins agains the rectangular prism the following error.
Model Errors: “The highlighted areas indicate missing or extraneous surfaces.” What can I do to the file? I am attaching the .skp and .stl.

ThanksBrady's Product.stl|attachment (305.4 KB)
Bradys design project.skp (365.5 KB)

I expect it’ll work better if he deletes the Follow Me path inside the hooks along with the circular faces where the hooks meet the rectangular prism.

If he wants the text to show as recessed, he’ll need to explode it and include that geometry as part of the rectangular prism.

Take a look at this one and compare it with his original.
Bradys design project.skp (285.5 KB)

Hi Dave! Thanks for your response! I was able to figure out how to delete the lines that created the “Follow Me”. When I deleted the circle it also deleted the hook. Please help:)

Hi Michael. Delete the faces of the circles, not the edges. You can hide the top face of the rectangular prism temporarily so you can see them. Then select the circle faces and hit Delete.

I will give that a try! Thanks again! My student and I will have to face that problem tomorrow a.m. While I wait, I am using “Free Sketchup”. Can you tell me where to find the tool to “Hide” the hook to delete the face?

Thanks again!

Hide is available in the Context menu. Right click on the face and you should see Hide near the top of the Context menu. If you go to Display (the glasses icon on the right, you can turn on Hidden Geometry. Then right click on the face, which will look like a mesh, and choose Unhide.